8

I realize there's probably a simple answer to this question. I come from Ubuntu (Unity) and am used to type unicode symbols with Ctrl+Shift+U, followed by the symbol's code and Enter.

This doesn't seem to work in Mint 17 (Cinnamon). I googled around and didn't find an answer to this.

How do you enter unicode symbols?

  • 2
    In what program? It seems to work on my Debian Edition when typing in the terminator terminal. Thanks, by the way, I didn't know that was possible. – terdon Jun 12 '15 at 17:38
  • 1
    What fonts are you using, do the have the unicode range that you are asking? – Anthon Jun 12 '15 at 17:41
2

You have probably figured out the answer for yourself by now. However, if anyone happens to google your question and end up here, the following steps fixed it for me:

  1. Navigate into your System Settings → Languages → Input Methods.

  2. If "IBus" is not available in the "Input Method" drop-down menu, click the "Add Support for IBus" button. Else, continue to step 3.

  3. Select "IBus" from the "Input Method" dropdown Menu.

  4. Restart your Machine.

1

I am using Cinnamon on Linux Mint 17.1. In my Gnome Terminal this works Ctrl+Shift+U then A, E, Space. (Enter works as well) to get the Registered symbol ® ( <- and firefox works as well), for which the unicode hex value is AE.

I don't recall ever enabling this, so it looks like there is something missing on your setup.

  • Unfortunately, it doesn't work for me. I wonder what's happening. – Sergio Jun 12 '15 at 18:03
  • 1
    @sergio That is difficult to diagnose, but I thought you wanted at least to know that it could work on Mint 17 (Cinnamon). If you move your account from Unity to Cinnamon, I would temporarily create a new user logout of Cinnamon, login as the new user and try again. To make sure it is your system and not some transferred config setting – Anthon Jun 12 '15 at 18:09
  • I used a separate partition for Mint so I don't think it would be that. I'll keep looking. – Sergio Jun 12 '15 at 18:53
  • @Sergio Not sure if it is of any help, but I am using the US English layout with euro on 5 – Anthon Jun 12 '15 at 19:00
  • And of course check that Ctrl+Shift is not taken by something else. – Anthon Jun 12 '15 at 19:05
1

Try reinstalling unicode

sudo apt-get install --reinstall unicode

Just done this myself and restarted, all fixed.

If applicable [sounds from question like it may well be], it's potentially to do with the way you go about 16 to 17 upgrade (OS wipe and reinstall vs. via less thorough apt-get).

I have a feeling this was the source of my problem - though I also installed the 'ancient' font to enable emojis on command line and read on the web that there have been bugs associated with this + that font.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.