0

I'm trying to install emacs and graphviz on my CentosBox. Its failing to resolve librsvg2:

$ sudo yum install emacs graphviz Loaded plugins: fastestmirror Setting up Install Process Loading mirror speeds from cached hostfile * base: mirrors.vooservers.com * epel: mirrors.coreix.net * extras: mirror.ukhost4u.com * rpmfusion-free-updates: mirrors.coreix.net * updates: centos.mirroring.pulsant.co.uk Resolving Dependencies --> Running transaction check ---> Package emacs.x86_64 1:23.1-25.el6 will be installed --> Processing Dependency: emacs-common = 1:23.1-25.el6 for package: 1:emacs-23.1-25.el6.x86_64 --> Processing Dependency: m17n-db-datafiles for package: 1:emacs-23.1-25.el6.x86_64 --> Processing Dependency: librsvg2 for package: 1:emacs-23.1-25.el6.x86_64 --> Processing Dependency: librsvg-2.so.2()(64bit) for package: 1:emacs-23.1-25.el6.x86_64 --> Processing Dependency: libotf.so.0()(64bit) for package: 1:emacs-23.1-25.el6.x86_64 --> Processing Dependency: libm17n-flt.so.0()(64bit) for package: 1:emacs-23.1-25.el6.x86_64 --> Processing Dependency: libm17n-core.so.0()(64bit) for package: 1:emacs-23.1-25.el6.x86_64 ---> Package graphviz.x86_64 0:2.26.0-10.el6 will be installed --> Processing Dependency: libgd.so.2()(64bit) for package: graphviz-2.26.0-10.el6.x86_64 --> Processing Dependency: libXaw.so.7()(64bit) for package: graphviz-2.26.0-10.el6.x86_64 --> Running transaction check ---> Package emacs.x86_64 1:23.1-25.el6 will be installed --> Processing Dependency: librsvg2 for package: 1:emacs-23.1-25.el6.x86_64 --> Processing Dependency: librsvg-2.so.2()(64bit) for package: 1:emacs-23.1-25.el6.x86_64 ---> Package emacs-common.x86_64 1:23.1-25.el6 will be installed ---> Package gd.x86_64 0:2.0.35-11.el6 will be installed ---> Package libXaw.x86_64 0:1.0.11-2.el6 will be installed ---> Package libotf.x86_64 0:0.9.9-3.1.el6 will be installed ---> Package m17n-db-datafiles.noarch 0:1.5.5-1.1.el6 will be installed --> Processing Dependency: m17n-db = 1.5.5-1.1.el6 for package: m17n-db-datafiles-1.5.5-1.1.el6.noarch ---> Package m17n-lib.x86_64 0:1.5.5-2.el6_1.1 will be installed --> Running transaction check ---> Package emacs.x86_64 1:23.1-25.el6 will be installed --> Processing Dependency: librsvg2 for package: 1:emacs-23.1-25.el6.x86_64 --> Processing Dependency: librsvg-2.so.2()(64bit) for package: 1:emacs-23.1-25.el6.x86_64 ---> Package m17n-db.noarch 0:1.5.5-1.1.el6 will be installed --> Finished Dependency Resolution Error: Package: 1:emacs-23.1-25.el6.x86_64 (base) Requires: librsvg-2.so.2()(64bit) Error: Package: 1:emacs-23.1-25.el6.x86_64 (base) Requires: librsvg2 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

I thought maybe there was another version of emacs available. So I check as per this question.

$ yum --showduplicates list emacs Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirrors.coreix.net * epel: mirrors.coreix.net * extras: mirror.mhd.uk.as44574.net * rpmfusion-free-updates: mirrors.coreix.net * updates: centos.mirroring.pulsant.co.uk Available Packages emacs.x86_64 1:23.1-25.el6 base

So if its the emacs that's part of the base centos package, why does it depend on librsvg2, which isn't part of centos?

0

When I looked up emacs via rpmfind I do see a dependency on the librsvg2 rpm. Try running rpmquery --requires and see if you don't see it as well.

In either case it is pretty simple to run yum -y install librsvg2 to add that package.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.