0

I'm having an issue with my Eclipse GUI. I'm not sure if it Linux specific or Eclipse specific. When I try to view list boxes or text areas, they don't show up. All I see is a grey box (or what I assume would be behind area.)

enter image description here

As you can see, the box is grey but we can see from the warning at the top of the window that the list does contain items.

This environment is running on a Virtual Box VM. I don't think this would be the cause of the problem as I have set up several development environments on VMs and never encountered this.

Linux Information:

# cat /proc/version
Linux version 3.10.0-229.4.2.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.2 20140120 (Red Hat 4.8.2-16) (GCC) ) #1 SMP Wed May 13 10:06:09 UTC 2015

System Information:

# lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 60
Model name:            Intel(R) Core(TM) i7-4800MQ CPU @ 2.70GHz
Stepping:              3
CPU MHz:               2665.142
BogoMIPS:              5330.28
L1d cache:             32K
L1d cache:             32K
L2d cache:             6144K
NUMA node0 CPU(s):     0,1

Eclipse Information:

Eclipse Java EE IDE for Web Developers.

Version: Luna Service Release 2 (4.4.2)
Build id: 20150219-0600
  • After adding --launcher.GTK_version 2 to eclipse.ini, eclipse crashes when accessing windows suffereing from the greyed out problem I mentioned above. – Native Jun 11 '15 at 19:24
  • Installing and switching to Gnome seems to have fixed the problem. Though I would rather KDE, I guess this'll work. – Native Jun 12 '15 at 13:20
  • I switched back to KDE, and found that the problem was with the Oxygen-GTK appearance. – Native Jun 12 '15 at 13:40
0

So I figured out the problem was with the oxygen-gtk widget style To change this setting, go to:

[System Settings > Application Appearance > Gtk+ Appearance]

From this window you can change the widget style to another style, such as "Adwaita". enter image description here

If you cannot see the "GTK+ Appearance" menu option you may have to get the GTK libraries.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.