2

I have the TP Link tl-wn822n ver. C (realtek chipset) wireless adapter and I am running Kali Linux from a live cd. After many hours trying to get around these problematic drivers, I managed to get them to work.

Issues

  • So now I can connect to the internet, but when I run the airmon-ng command the interface of the adapter does not show up.
  • When I run the airmon-zc command I get the interface as wlan1 but the PHY field is null so I can't get a monitor interface with airmon-ng start wlan1 command.

Any suggestions on how I can assign it manually maybe?

0

You need to run:

ifconfig wlan0mon down
iwconfig wlan0mon mode monitor
ifconfig wlan0mon up

After you run these commands, airodump-ng wlan0mon will work.

  • Actually, you just copy-pasted from HERE – don_crissti Nov 29 '15 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.