0

I'm on Manjaro xfce latest update 64 bit, I have Jbl charge 2, I was able to connect to it and trust it through bluetooth. The thing I don't know how to stream my laptop's audio through it. I played around with PulseAudio volume control, changed settings and stuff, got nothing. So how to do it?

seems like a blueman problem, I think I see this error

Bluetooth device added successfully but failed to connect
0

solved by installing pulseaudio-bluetooth, I'm still configuring it for the audio to work properly but this is a starting point

  • Any update after install pulseaudio-bluetooth? How does one tell pulseaudio to play on bluetooth device? – Gabriel Ziegler Dec 25 '18 at 19:07
  • @GabrielZiegler I'm no longer on Mangaro, I'm on ubuntu 16.04, but I still have the speaker if you want me test it on ubuntu and see if everything is working, because I haven't tested it yet. – Lynob Dec 25 '18 at 19:49
  • I just it solved, I can post the step-by-step to my solution on getting everything done later, thanks for the will to help tho – Gabriel Ziegler Dec 25 '18 at 20:17
  • @GabrielZiegler If you post your answer, I'll accept and upvote it – Lynob Dec 25 '18 at 20:19
0

I have connected my Bose Color II on my Arch Linux following a few steps from the Arch Wiki:

  1. Install the dependencies.
pacman -Syu bluez bluez-utils
  1. Start the bluetooth service(Alternatively enable it to skip this step in the next times).
systemctl start bluetooth.service
  1. Run the Bluetooth service shell.
bluetoothctl
  1. An example session taken from the wiki:
# bluetoothctl 
[NEW] Controller 00:10:20:30:40:50 pi [default]
[bluetooth]# agent KeyboardOnly 
Agent registered
[bluetooth]# default-agent 
Default agent request successful
[bluetooth]# power on
Changing power on succeeded
[CHG] Controller 00:10:20:30:40:50 Powered: yes
[bluetooth]# scan on
Discovery started
[CHG] Controller 00:10:20:30:40:50 Discovering: yes
[NEW] Device 00:12:34:56:78:90 myLino
[CHG] Device 00:12:34:56:78:90 LegacyPairing: yes
[bluetooth]# pair 00:12:34:56:78:90
Attempting to pair with 00:12:34:56:78:90
[CHG] Device 00:12:34:56:78:90 Connected: yes
[CHG] Device 00:12:34:56:78:90 Connected: no
[CHG] Device 00:12:34:56:78:90 Connected: yes
Request PIN code
[agent] Enter PIN code: 1234
[CHG] Device 00:12:34:56:78:90 Paired: yes
Pairing successful
[CHG] Device 00:12:34:56:78:90 Connected: no
[bluetooth]# connect 00:12:34:56:78:90
Attempting to connect to 00:12:34:56:78:90
[CHG] Device 00:12:34:56:78:90 Connected: yes
Connection successful

After pairing your audio streaming device, I suggest you to use pavucontrol to choose the Bluetooth device as the output device.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.