6

I'd like to remote access a desktop of a specfic user and not a root desktop; however when I run the vncserver it always produces a rooted desktop.

This could be related to the installation of tigervnc. The .vnc and .xauthority directories are found in /root directory.

How can I change this so that I can run vncserver at :1 and produce a specific user desktop?

I also tried using the vncserver -u username command but it will not let me access the .vnc files.

I think that tigervnc has to be removed and installed in the right locations?

  • 2
    The VNC server will not run as root unless you actually start it as root. It simply runs under whatever user you start it as. So how are you starting it? – Celada Jun 10 '15 at 2:32
  • 1
    I have to start the vnc server with the root@localhost using the command "vncserver". It will not start using another user account. – Nacho de Leon Jun 10 '15 at 22:01
  • Facing the same issue. @NachodeLeon: any luck? – dirtyhandsphp Mar 29 '17 at 13:34
  • Unfortunately, no. – Nacho de Leon Mar 30 '17 at 16:58
1

Just struggled with this problem for some days and managed to solve it using:

  1. Log out and make sure no other user logged-in
  2. Log in again as user using TERMINAL, do not use gdm/xdm or graphical manager to login
  3. Start vncserver in terminal
  4. In terminal issue startx

What I guess that is happening is that systemd starts the X server and it is run under root user. When somebody login it probably opens a new process and uses setuid syscall to set all permissions to the uid that has just logged in. This probably blocks vncserver from getting data from X server for the same user afterwards.

Maybe some kind of systemd configuration or permission changing in filesystem will resolve it as well...

0

you try https://wiki.ubuntu.com/xdmcp it has Multi-user mode https://wiki.archlinux.org/index.php/TigerVNC#Multi-user_mode plan to try this myself in that it may work around the vnc debian grey screen / :( issue better than the mate/lxde installation fix.

have you tried xdmcp remote desktop - it has multi-user mode - it may solve your multi-user issue and other issues encountered with vnc and debian.... per jasonwryan 'essential parts' without links - edit

0

1.Run the vnc servers as root 2.Copy /root/.vnc/xstartup to /home/user/.vnc ( create .vnc if not already created) 3.login to user 4.start vncserver( # vncserver -geometry 1024x768 -depth 16 -name remote-desktop :1)
5.vncpasswd for setting vnc password
6.try to login through vnc viewer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.