1

I'm on Raspberry pi 2, running Raspian, and using Ubuntu 14.04. I am using the tightvncserver. I don't think I should have to start a new 'X' desktop each time I want to VNC into the pi, but whenever I tried to vnc into the previously established :0 or :1 it told me that it was "closed" and refused to connect. This is after running:

 vncserver :0 -geometry 1920x1080 -depth 24

I got it running by typing the same thing with a :2 and then vnc-ing in, but I think there's another way.

migrated from raspberrypi.stackexchange.com Jun 9 '15 at 16:31

This question came from our site for users and developers of hardware and software for Raspberry Pi.

  • When you connect on :2 are the previously started vncserver processes still running? – Dan Cornilescu Jun 9 '15 at 17:17
  • I put into the command line "vncserver -kill :0" which it told me couldn't be done. I wasn't sure if this meant the other processes were still running or I just have no idea what I'm doing...probably both – MJAFort Jun 9 '15 at 17:52
  • Well, if the server is no longer running it explains why you can't re-connect to it :) You need to explain where that 'kill' fits into the picture. Also might help if you describe how you end your VNC session. – Dan Cornilescu Jun 9 '15 at 19:04
  • I end the VNC session by closing the VNc window as expalined here: link. The funny part is that when I go into recent connections to reconnect and click on any of the previous options it tells me it's closed. If I enter in the command I have in the original question it says it can't do that because there is some kind of tmp file, sort of like what ubuntu 12 used to do if you closed the lid without suspending, but I have no idea how to get rid of these files. – MJAFort Jun 9 '15 at 19:29
  • Right now I've got it sort of working via going through and sudo rm-ing all the files it outlines as causing issues, but this seems a little janky and unreliable as well as tedious. Is there something else I should be doing, or is this relly the best way to do this. – MJAFort Jun 9 '15 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.