1

Unless I set "Seconds between keepalives (0 to turn off)" to 2 putty keeps disconnecting after a few minutes of inactivity. How can I fix this once and for all? I can't find where putty settings are stored on my PC

  • why not check "Enable TCP keepalives" ? – Archemar Jun 9 '15 at 14:39
  • I can do that but it doesn't save. Every time I open putty I need to set that. How can I set it permanently? – Teddy291 Jun 9 '15 at 14:50
  • 1
    Change it and save in default profile – Romeo Ninov Jun 9 '15 at 14:51
2

Putty settings can only be saved if assigned to a saved session.

The process is usually to configure putty as you like, go back to the first Category ("session"), enter a name, and click "Save" to save your settings.

If you don't want to have to load the session each time,you have to save the session as "Default Settings" in the saved sessions list.

1

If you have trouble saving this on the client site for some reason, you could consider setting it on the server side (assuming you have root access there) in /etc/ssh/sshd_config:

TCPKeepAlive yes
  • Could you please tell is it same to setting ServerKeepAlive <sec> in client conf file /etc/ssh/ssh_config ? – heemayl Jun 9 '15 at 15:31
  • @heemayl I am not sure if putty reads that. I know that ssh does and for the ssh-client you can set that in that file. – Anthon Jun 9 '15 at 15:33
  • Actually i have referred to openssh-client ..just curious..so i can set any one? either in server or client? – heemayl Jun 9 '15 at 15:34
  • 1
    For the ssh client you can set it there, or in ~/.ssh/config for the client and like I indicated in my answer for the server – Anthon Jun 9 '15 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.