2

This is where I am so far with my download after I was stranded in the middle of the way. So I went to the website, downloaded the latest version of Tomcat, and I extracted it into my downloads. I have been trying to add CATALINA_HOME to JAVA_HOME and this is not working. I have looked for tutorials, but nothing seems to work. I am not well versed with vim.

So where do I go from here?

It works !

If you're seeing this page via a web browser, it means you've setup Tomcat successfully. Congratulations!

This is the default Tomcat home page. It can be found on the local filesystem at: /var/lib/tomcat7/webapps/ROOT/index.html

Tomcat7 veterans might be pleased to learn that this system instance of Tomcat is installed with CATALINA_HOME in /usr/share/tomcat7 and CATALINA_BASE in /var/lib/tomcat7, following the rules from /usr/share/doc/tomcat7-common/RUNNING.txt.gz.

You might consider installing the following packages, if you haven't already done so:

tomcat7-docs: This package installs a web application that allows to browse the Tomcat 7 documentation locally. Once installed, you can access it by clicking here.

tomcat7-examples: This package installs a web application that allows to access the Tomcat 7 Servlet and JSP examples. Once installed, you can access it by clicking here.

tomcat7-admin: This package installs two web applications that can help managing this Tomcat instance. Once installed, you can access the manager webapp and the host-manager webapp.

NOTE: For security reasons, using the manager webapp is restricted to users with role "manager-gui". The host-manager webapp is restricted to users with role "admin-gui". Users are defined in /etc/tomcat7/tomcat-users.xml.

  • 1
    Could you edit your question to give more detail of what you tried to do and what isn't working? Also, you might find that sudo apt-get install tomcat7 gives you a good enough version of Tomcat without all the trouble... – Stephen Kitt Jun 9 '15 at 4:47
  • Hey i just want to install TomCat in my os. – Madona Syombua Jun 9 '15 at 13:22
  • @StephenKitt after installing this is what i have am i okay to go? thanks i advance. I was trying to download 8 but i didnt find good tutorials for it and the correct apt-get – Madona Syombua Jun 9 '15 at 13:33
  • Yes, you're good to go! – Stephen Kitt Jun 9 '15 at 13:36
1

The simplest solution on Mint is to install the tomcat7 package, if Tomcat 7 is good enough:

sudo apt-get install tomcat7

Once that's done, you can drop your webapps in /var/lib/tomcat7/webapps and they will deploy automatically. You can also install the tomcat7-admin package and configure users as described in the documentation you quote, and you'll get the Tomcat administration applications.

If you really need Tomcat 8, you can download it from Debian or Ubuntu and install it on Mint:

wget https://launchpad.net/ubuntu/+archive/primary/+files/tomcat8_8.0.23-1_all.deb https://launchpad.net/ubuntu/+archive/primary/+files/tomcat8-common_8.0.23-1_all.deb https://launchpad.net/ubuntu/+archive/primary/+files/libtomcat8-java_8.0.23-1_all.deb https://launchpad.net/ubuntu/+archive/primary/+files/libservlet3.1-java_8.0.23-1_all.deb
sudo dpkg -i tomcat8_8.0.23-1_all.deb tomcat8-common_8.0.23-1_all.deb libtomcat8-java_8.0.23-1_all.deb libservlet3.1-java_8.0.23-1_all.deb

With Tomcat 8 webapps go in /var/lib/tomcat8/webapps.

  • I need tomcat8 too.I was just wondering i can have both 7-8? – Madona Syombua Jun 9 '15 at 13:46
  • 1
    Yes, they're co-installable, but you'll need to configure them to use different port numbers. – Stephen Kitt Jun 9 '15 at 14:00
  • Hey i did configure and gave them different pots but it wont work, so i decided to remove the 7 and remain with the latest version so i ran this (sudo apt-get remove tomcat7 tomcat7-docs tomcat7-admin tomcat7-examples default-jdk ant git) and it was removed but i dont know why installing Tomcat 8 is difficult. I went to the website and downloaded the src and extracted in my home, and ran the commands you gave but the second dpkg tells me operation requires superuser priviledge – Madona Syombua Jun 9 '15 at 15:46
  • Sorry, dpkg needs to run as root. – Stephen Kitt Jun 9 '15 at 15:47
  • I was also trying this (sudo apt-get install tomcat8 Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package tomcat8) – Madona Syombua Jun 9 '15 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.