3

I am trying to troubleshoot an issue with a fuse library, where my fuse file system is mysteriously unmounted shortly after mounting it.

After screwing around with a bespoke unmount executable that logged evidence about its invoker, I found that systemd is the culprit. Indeed /var/log/syslog contains lots of messages like this:

Jun  8 06:39:41 ubuntu systemd[1]: Unit tmp-fusetest301566509.mount is bound to inactive unit dev-fuse.device. Stopping, too.
Jun  8 06:39:41 ubuntu systemd[1]: Unmounting /tmp/fusetest301566509...

I don't know the first thing about configuring systemd. Where should I look to figure out why it thinks it is allowed to unmount my file systems without me telling it to?

I'm running Ubuntu 15.04:

% uname -a
Linux ubuntu 3.19.0-16-generic #16-Ubuntu SMP Thu Apr 30 16:09:58 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Update: I should clarify that there are no entries related to this path or /dev/fuse in /etc/fstab.

| improve this question | | | | |
  • 1
    Maybe related to unix.stackexchange.com/questions/169909/… – coteyr Jun 8 '15 at 10:53
  • 1
  • Thanks, but those appear to be caused by a need to rescan /etc/fstab. I don't have any relevant entries there. (I've updated the question.) – jacobsa Jun 8 '15 at 12:19
  • 1
    Okay, so I take it back: I tried systemctl daemon-reload anyway, and the problem appears to have gone away. But I don't understand why. :-/ – jacobsa Jun 8 '15 at 12:26
  • Nevermind, I had mixed up two things I tried. The actual reason it appears to have stopped is that I updated my fuse program to set a name for the file system, rather than using the default of /dev/fuse. That appears to keep systemd out of its business. – jacobsa Jun 8 '15 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.