1

I have a FAMP SERVER I'm setting up.

  1. FreeBSD 10.1
  2. Apache 2.4
  3. MySQL 5.6
  4. Php 5.6

Everything working ok so far. I installed symfony no problem but now trying to install composer.

curl -sS https://getcomposer.org/installer | php

I get the following output (see below) but I don't know how to correct the problem.

Tried review of Php.ini and the make file on mod_php56 in usr/ports.


#!/usr/bin/env php

Some settings on your machine make Composer unable to work properly. Make sure that you fix the issues listed below and run this script again:

The json extension is missing. Install it or recompile php without --disable-json

The phar extension is missing. Install it or recompile php without --disable-phar

The filter extension is missing. Install it or recompile php without --disable-filter

The hash extension is missing. Install it or recompile php without --disable-hash

The openssl extension is missing, which means that secure HTTPS transfers are impossible. If possible you should enable it or recompile php with --with-openssl code here

1

Ok I figured It out

I needed to run pkg install php56-[missng module name]-5.6.9 For each of the above modules (in fact hash came with one of the others)

I also ran pkg install OpenSSL but I'm not sure if I needed to go that or not.

  • It also added recommendations to install intl module and an accelerator. but I haven't figured out that yet and when running composer install many other modules (following the same naming patterns) were also required – MB. Jun 8 '15 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.