0

Sorry for my bad english. On a distribution debian wheezy I configured a router AP. I set up a bridge between a VLAN eth0.102 and wlan wlan0. For configuring WiFi I installed the drivers for the wireless device. I configured the file hostapd.conf and dhcp server, use dnsmaq. Everything works fine until suddenly a wireless client any, by any operation the apparatus AP router crashes, you can not longer access the device is in wireless connectivity with the cable and disappears, every activity of the apparatus is turned off . I tried to check the log file, but when the system is restarted you lose all the log file pre-block. I tried several times to redo the configuration, fearing that he had made some mistakes, but the event lock apparatus occurs equally. Note that at the weekend, when no client is connected to the router, the device will not lock. The block happens the following working day, even after several hours of work. In fact these devices I 2 configured identical, both as hardware and as software. On one I have at my house did not have any type of problema.Ho connected two computers, two notebooks a wii, three phones Android, a PBX with two phones and a wireless printer. The other one that I installed in the office where I happen the problems I have explained before, I connected a PC, a photocopier network, a PC wirless, four notebooks, a wireless printer, a PBX with three phones. These are my configuration files:

# brctl show 
bridge name     bridge id               STP enabled     interfaces 
br0             8000.024c0a813951       yes             eth0.102
                                                        wlan0 

# /etc/dnsmasq.conf interface=br0 dhcp-range=192.168.8.2,192.168.8.254,255.255.255.0,12h dhcp-option=252,"\n" dhcp-authoritative

# cat etc/hostapd/hostapd.conf ssid=Myssid wpa_passphrase=mypassword # ctrl_interface=/var/run/hostapd ctrl_interface_group=0 interface=wlan0 bridge=br0 driver=rtl871xdrv hw_mode=g channel=4 wpa=3 logger_syslog=-1 logger_syslog_level=2 logger_stdout=-1 logger_stdout_level=2 beacon_int=100 dtim_period=2 ieee80211n=1 country_code=IT auth_algs=3 wmm_enabled=1 wmm_ac_bk_acm=0 wmm_ac_bk_cwmin=4 wmm_ac_bk_cwmax=10 wmm_ac_bk_aifs=7 wmm_ac_bk_txop_limit=0 wmm_ac_be_aifs=3 wmm_ac_be_cwmin=4 wmm_ac_be_cwmax=10 wmm_ac_be_txop_limit=0 wmm_ac_be_acm=0 wmm_ac_vi_aifs=2 wmm_ac_vi_cwmin=3 wmm_ac_vi_cwmax=4 wmm_ac_vi_txop_limit=94 wmm_ac_vi_acm=0 wmm_ac_vo_aifs=2 wmm_ac_vo_cwmin=2 wmm_ac_vo_cwmax=3 wmm_ac_vo_txop_limit=47 wmm_ac_vo_acm=0 ht_capab=[HT40+][SHORT-GI-20][SHORT-GI-40] max_num_sta=255 preamble=1 macaddr_acl=0 ignore_broadcast_ssid=0 wpa_key_mgmt=WPA-PSK rsn_pairwise=CCMP wpa_pairwise=TKIP CCMP wpa_group_rekey=600

I had to disable the line "ctrl_interface = / var / run / hostapd" otherwise the command to restart the service hostapd me back an error

# /etc/init.d/hostapd restart
[ ok ] Stopping advanced IEEE 802.11 management: hostapd.
[FAIL] Starting advanced IEEE 802.11 management: hostapd failed!

#cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
# Wan settings
auto eth0.101
iface eth0.101 inet dhcp
#Switch
auto eth0.102
iface eth0.102 inet manual
  pre-up ifconfig $IFACE up
  post-down ifconfig $IFACE down
# wireless settings
auto wlan0
iface wlan0 inet manual
  pre-up ifconfig $IFACE up
  post-down ifconfig $IFACE down
#Bridge
auto br0
iface br0 inet static
bridge_ports eth0.102 wlan0
address 192.168.8.1
netmask 255.255.255.0
broadcast 192.168.8.255
network 192.168.8.0
up /sbin/brctl stp br0 on
up iptables-restore < /etc/iptables.ipv4.nat 

Can someone please help me? Thanks!!

0

May be a firmware issue, Debian does not come with device firmwares pre installed, most wireless cards needs proper firmware to work.

  • what is your ethernet and wi-fi hardware ?
  • try again after installing these packages and a reboot

    sudo apt-get install firmware-linux firmware-linux-free firmware-linux-nonfree firmware-atheros firmware-brcm80211

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.