I have CentOS 6.6 (32-bit) running in VMware Workstation 10.0.3 build-1895310. I have just modified the Virtual Machine Settings, expanding the Hard Disk from 20 GB to 30 GB. I also created a new partition of type primary, sda4, with default start and stop cylinder number.

fdisk /dev/sda returns this:

Disk /dev/sda: 32.2 GB, 32212254720 bytes
255 heads, 63 sectors/track, 3916 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0000fba6

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          64      512000   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              64        2611    20458496   8e  Linux LVM
/dev/sda4            2611        3916    10483750   83  Linux

When I try to mount it, using mount -t ext4 /dev/sda4 /data, the following error is shown:

mount: wrong fs type, bad option, bad superblock on /dev/sda4,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

To get the filesystem type, I typed the command df -T, and had the output below:

Filesystem           Type  1K-blocks    Used Available Use% Mounted on
                     ext4   17971068 4039580  13011936  24% /
tmpfs                tmpfs    514720     228    514492   1% /dev/shm
/dev/sda1            ext4     487652   66444    395608  15% /boot
  • here link a similar problem is formulated, but the answer provided needed gparted installed. since I failed to install gparted, I could not apply the solution presented there. Jun 7, 2015 at 14:04

1 Answer 1


You need to create a filesystem on the new partition still. You created the partition, but it doesn't have a filesystem on it (as shown by its lack of entry in df -T).

Do mkfs -t ext4 /dev/sda4 then try to mount it after

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .