I want to install CodeLite. I followed the instructions on the website.
Because I'm running Linux Mint 17.1 x64, I added repositories for ubuntu utopic, trusty and vivid universe.
Now when I run
apt install codelite wxcrafter I get:
codelite : depends: libglib2.0-0 (>= 2.41.1) but 2.40.2 is installed instead-0ubuntu1 depends: libhunspell-1.3-0 (>= 1.3.3)but 1.3.2-6ubuntu2 is installed instead depends: liblldb-3.4 but is not installable depends: libstdc++6 (>= 4.9) but 4.8.2-19ubuntu1 is installed instead suggests: nodejs but is not going to be installed
I tried the answer on this question but the links given are broken.
I think the problem is that some dependencies are either new for my Mint (aka libglib2) or somewhat old (aka liblldb).
I can see liblldb-3.5 with
Installing it didn't remove "depends: liblldb-3.4" line.
I tried looking for libglib2.0-0. I found version 2.44 on Debian's page and downloaded it, but installing it has broken my system and I had to format my hard drive.
So what to do to install CodeLite 8 on Linux Mint 17.1 64-bit Cinnamon?