1

I just installed up arch x64 running on BIOS configuration using vmware workstation 11.1.

Everything is fine and working as intended except vmware shared folders feature. I have been continuously working on results from Google searches to try getting it to work but to no avail.

First, the methods I have tried include (but not limited to):

  • Using installer script from here (although its clearly mentioned in post itself that shared folders won't work so...).

  • Compiling vmware patches from https://github.com/rasa/vmware-tools-patches (I just did exactly as its told in readme, nothing more just in case).

  • Manual usual installation of vmware tools from selecting install vmware tools option from vmware workstation.

  • Try the "manually mounting and adding service to systemd" method from arch wiki-> https://wiki.archlinux.org/index.php/VMware/Installing_Arch_as_a_guest (sorry not allowed to post in more than one link so...). In this case it didn't even boot completely. The error message was similar to shared directory not found.

  • open-vm-tools and open-vm-tools-dkms from repository.

  • A couple of other methods that I probably can't remember.

NOTE: When I tried to mount shared folders manually using mount -n -t vmhgfs .host:/<shared_folder> /home/myname/shares, this turned off cpu inside virtual machine and everything in virtual machine (arch) freezed, forcing me to reset it to no avail.

So in short, is it even possible to use shared folders in arch at present?

  • If you install the vmware tools provided by vmware, are there any error messages when you run vmware-config-tools.pl and compile the shared folders driver? – Mark Plotnick Jun 7 '15 at 2:08
  • Yes, it gave me an error similar to "Failed to Start vmghfs service". – user3271166 Jun 7 '15 at 3:50
  • Was that preceded by any C compilation errors? – Mark Plotnick Jun 7 '15 at 3:52
  • No, there wasnt any compile time error but when I tried to mount it manually using "mount -n -t vmhgfs .host:/<shared_folder> /home/user1/shares", this turned off cpu and everything inside virtual machine freezed, forcing me to reset it to no avail (sry forgot to mention it, edited the post). – user3271166 Jun 7 '15 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.