1

In my bash 4.2.46 and centos - 7.1.1503, I ran set -x (to print debug info). Now, if I type ls, it prints:

+ ls --color=auto
a    b   c
++ printf '\033]0;%s@%s:%s\007' root sk-vbox '~'

All well and happy. But when I press tab on a shell variable for completion, it prints output without stack info:

echo $HO  #tab key press here

gives:

$HOME      $HOSTNAME  $HOSTTYPE  

and zero lines of stack info.

I need this stack information badly to debug an issue in which bash puts extra space on autocompletion (similar to acroread issue but possibly due to a different reason since /etc/bash_completion.d doesn't contain the culprit, acroread.sh in my case.)

I'm using bash 4.2.46 on CentOS Linux release 7.1.1503.

  • Please edit your question and include your operating system and bash version. I can't reproduce this on Debian and bash v4.3.33. Hitting tab does print the stack info. – terdon Jun 6 '15 at 13:50
  • bash - 4.2.46 and centos - CentOS Linux release 7.1.1503. I tried upgrading to the newest bash in the town, but yum update bash replies No packages marked for update. so i am struck with 4.2.46 – Madhavan Jun 6 '15 at 13:53
  • Are you sure you have configurable completion active in that shell, and not the built-in stuff? If you run bash --norc, you get the built-in stuff, which executes to bash code so prints no trace. You need to source /etc/bash_completion to get the configurable completion. Does e.g. rpm -q complete package names or files? – Gilles Jun 6 '15 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.