3

I am using samba under ubuntu 14.04 and I try to share a folder which includes a symlink to a directory that lies on an external drive. If I access the samba share from other devices (like android phone or windows PC) it does not show the symlink - everything else works fine. I found multiple solution suggestions but nothing worked. Currently I added the following lines in the global section before I restarted samba:

follow symlinks = yes
unix extensions = no
wide links = yes
allow insecure wide links = yes

However it does not change anything. I am aware of the security risks, but in this case it is no problem. Can anyone help here?

  • Could it be SELinux interfering? Try "grep smbd /var/log/audit/audit.log" or "sealert" to check. I believe there are SELinux boolean settings to have certain daemons follow symlinks above and beyond the program's own restrictions. – Aaron D. Marasco Jun 6 '15 at 1:28
  • I did not install or enable SELinux so I think it should not be active after installing standard ubuntu 14.04, right? I can check the logs later though, just to make sure. – valenterry Jun 6 '15 at 2:05
1

Interestingly it worked after I rebooted the machine. Stopping samba (I checked it - didn't get a connection anymore) and starting it again doesn't seem to apply the changes. Do I miss something here, is this expected behaviour? Im glad though that it works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.