13

I'm using Debian 8, but my integrated graphics card does not seem to be used.

This is on an Asus Zenbook UX303 which uses HD 5500 integrated graphics:

$ sudo lspci -vnn | grep VGA -A 12
00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device [1043:183d]
    Flags: bus master, fast devsel, latency 0, IRQ 64
    Memory at f6000000 (64-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at f000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915

It seems to say there is a driver in use, however, it doesn't seem the machine is actually using that graphics card:

$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)
OpenGL version string: 3.0 Mesa 10.3.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

How do I get debian to actually use the integrated graphics card?

$ uname -a
Linux zenbook 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt9-3~deb8u1 (2015-04-24) x86_64 GNU/Linux

I've also tried the 4.0.2 kernel from unstable, which doesn't change anything; uname:

$ uname -a
Linux zenbook 4.0.0-1-amd64 #1 SMP Debian 4.0.2-1 (2015-05-11) x86_64 GNU/Linux
31

Unfortunately Jessie as released doesn't fully support Broadwell graphics. The required drivers have been backported though, so if you enable Jessie backports you can fix this.

First you need to add Jessie backports to your repositories, if it's not already there (thanks to Anders for the reminder to use a separate file):

echo deb http://http.debian.net/debian jessie-backports main > /etc/apt/sources.list.d/jessie-backports.list

(as root), then

apt-get update
apt-get -t jessie-backports install xserver-xorg-video-intel

should allow X to use your HD 5500 properly.

Enabling backports is safe: newer packages are not picked up automatically from backports, you need to explicitly select them using -t jessie-backports as above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.