1

I just tried booting up a Debian ARMel build using QEMU on my Ubuntu machine as follows :-

qemu-system-arm -M versatilepb -kernel vmlinuz-3.2.0-4-versatile -initrd initrd.img-3.2.0-4-versatile -hda debian_wheezy_armel_desktop.qcow2 -append "root=/dev/sda1"

But I get this error message:

qemu-system-arm: -hda debian_wheezy_armel_desktop.qcow2: 'scsi0-hd0' uses a qcow2 feature which is not supported by this qemu version: QCOW version 3

I have not come across any way to convert qcow2 to qcow3; does anyone know what the latest qemu version that supports qcow2 is? I'd like to try installing that.

  • What's the error that makes you think it doesn't understand qcow2? Also, qemu-img may be able to convert to qcow3, though I haven't tried myself – Eric Renouf Jun 4 '15 at 18:38
  • @EricRenouf Thanks. I've pasted the error message. I tried using qemu-img, but it too complains about now being able to work with qemu2. – user3655 Jun 4 '15 at 18:40
1

Given that error message it seems, according to this site that the problem may have been with how virt-manager created the image, and you might be able to use qemu-img after all like so:

qemu-img convert -f qcow2 -O qcow2 -o compat=0.10 $ORIGPATH $NEWPATH

to convert from a "broken" qcow2 to a usable qcow2 file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy