I'm trying to configure an FTP server on debian 8. I'm using the basic conf file of proftpd, found here

Now when I try to start the server I get this error:

 Starting proftpd (via systemctl): proftpd.serviceJob for proftpd.service failed. See 'systemctl status proftpd.service' and 'journalctl -xn' for details.


juin 04 10:47:52 client1 proftpd[2325]: Starting ftp server: proftpd2015-06-04 10:47:52,978 client1 proftpd[2331]: fatal: unknown configuration directive 'DisplayF
juin 04 10:47:52 client1 proftpd[2325]: failed!
juin 04 10:47:52 client1 systemd[1]: proftpd.service: control process exited, code=exited status=1
juin 04 10:47:52 client1 systemd[1]: Failed to start LSB: Starts ProFTPD daemon.
-- Subject: L'unité (unit) proftpd.service a échoué
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- L'unité (unit) proftpd.service a échoué, avec le résultat failed.
juin 04 10:47:53 client1 systemd[1]: Unit proftpd.service entered failed state.

Any idea about the problem?


May be you have error in your proftpd config file. You have to perform configuration check. The easiest way to do informative syntax check as is stated here is to run:

proftpd -td10

or you can run (less noise):

proftpd -td5

For sample config in your question, the result is:

2015-06-04 12:05:43,290 debian proftpd[22458]: using PCRE 8.35 2014-04-04
2015-06-04 12:05:43,291 debian proftpd[22458]: using TCP receive buffer size of 87380 bytes
2015-06-04 12:05:43,291 debian proftpd[22458]: using TCP send buffer size of 16384 bytes
2015-06-04 12:05:43,292 debian proftpd[22458]: mod_memcache/0.1: using libmemcached-1.0.18
2015-06-04 12:05:43,293 debian proftpd[22458]: <Directory />: adding section for resolved path '/'
2015-06-04 12:05:43,293 debian proftpd[22458]: fatal: unknown configuration directive 'DisplayFirstChdir' on line 53 of '/etc/proftpd/proftpd.conf'

So may be you have to comment line:

DisplayFirstChdir       .message
  • The command proftpd -td5 helped me to clearly see where the error ist, though I have another error. – loved.by.Jesus Aug 20 '19 at 9:05

According to http://www.proftpd.org/docs/directives/linked/config_ref_DisplayChdir.html the DisplayFirstChdir directive has been obsoleted by DisplayChdir with the supplementary true parameter.

So instead of:

DisplayFirstChdir .message

You now need:

DisplayChdir .message true

If you want the message displayed every time someone enters that directory, omit the true.

How did I find this out? I went to the website for ProFTPd and looked in the documentation, finding Directives By Name. It became apparent that DisplayFirstChdir was not a valid verb, so I looked at the nearest equivalent by name.


I solved this problem removing the main FTP configuration file /etc/proftpd/proftpd.conf and then restarting the service

sudo service proftpd restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.