0

I'm new with Solaris. I cloned a Solaris 11 machine and now I'm trying to change it so that it gets the hostname and DNS name from a DHCP client. I tried following the instructions here: https://blogs.oracle.com/VDIpier/entry/solaris_11_changing_the_hostname but when reconnecting to the console I get the old hostname.

  • Is this a virtual machine? – Mark Plotnick Jun 4 '15 at 8:29
  • yes, it's a virtual machine – furni Jun 5 '15 at 11:40
0

Maybe you're just seeing an unchanged /etc/issue or something like that? When you log in again, and run hostname, does it show the new hostname? If so, that's it.

|improve this answer|||||
  • no, I still see the old hostname, even though I made the changes for nodename and loopback – furni Jun 5 '15 at 11:42
  • @furni and does svccfg -s system/identity:node listprop config show the new hostname? – Josip Rodin Jun 5 '15 at 16:23
  • reboot solved all my problems – furni Jun 26 '15 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.