0

I'm needing a tomcat version which supports JDK 8. So since I was using tomcat6, I need to switch to tomcat 7.

The problem comes because, when I install it using:

apt-get install tomcat7

The version I get is 7.0.26, and as you can read here, this version doesn't have JDK8 support yet.

So I need to update/install to/the newest version of tomcat 7 to ensure about it (released of course).

The only requirement by my side is to install it as apt-get does, I mean, being able to use it as service (service tomcat7 start, and all this stuff), so don't want to install it by downloading, unzip and run.

I've tried to look for another repositories and then run apt-get, but I couldn't do it (tried to add another repository, but didn't work...)

Could you explain me how to do it?

Thank you in advance

PS: just to clarify, this is expected to run in Elementary OS, but the real target OS is a Guadalinex distro ("spanish" (andalusian) distro, based on Ubuntu), so could you tell me if I can use the same steps for this OS too? (Thanks!)

3

This isn't quite as simple as using apt-get, but the result will be the same. If you download the packages for Tomcat 7.0.62 from Ubuntu, they should install fine in elementary OS and support Java 8.

You'll need to click on the little triangle to the left of "The Wily Werewolf", and download the .deb files you need: at least libservlet3.0-java, libtomcat7-java, tomcat7-common and tomcat7. You can then install them using

dpkg -i libservlet3.0-java_7.0.62-1_all.deb libtomcat7-java_7.0.62-1_all.deb tomcat7-common_7.0.62-1_all.deb tomcat7_7.0.62-1_all.deb
  • after installing it as you said, I can start it but got some errores. After checking it, I found my tomcat is running (service tomcat7 status say it), but if I run /usr/share/tomcat7/bin/configtest.sh it warns me of some folders that don't exist, plus the /conf/server.xml file neither (nor the conf folder). Any idea about why is this happening? =( – Btc Sources Jun 3 '15 at 19:34
  • What does ls -ld /var/lib/tomcat7/conf say? It should be a link to /etc/tomcat7 where you should find the configuration files... If not, try dpkg --purge tomcat7 followed by dpkg -i tomcat7_7.0.62-1_all.deb to reinstall the tomcat7 package completely (that's the one containing the configuration). – Stephen Kitt Jun 3 '15 at 20:11
  • ls says it exist, but this is not the path where configtest.sh is trying to find it! (/usr/share/tomcat7/conf/server.xml) – Btc Sources Jun 3 '15 at 20:38
  • Ah, I see; checking on my system indicates that configtest.sh doesn't work with the way the packages are set up in Debian and its derivatives (including Ubuntu and elementary OS). What errors do you get when starting Tomcat? – Stephen Kitt Jun 3 '15 at 20:42
  • I get no errors at launch, but when trying to access to my JSP app (tested in tomcat6 before needed JDK8), it says it cannot load some clases (error 500) and doesn't give any code line of my files in the stacktrace. PS: I'm starting tomcat using service tomcat7 start. – Btc Sources Jun 3 '15 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.