1
xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr: Failed to get size of gamma for output default
xrandr --addmode Screen 0 "1280x1024_60.00"xrandr: unrecognized option '1280x1024_60.00'

So while it says it's an unrecognized option, running xrandr will display the newmode:

Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480       73.00* 
  1280x1024_60.00 (0x206) 109.000MHz
    h: width  1280 start 1368 end 1496 total 1712 skew    0 clock  63.67KHz
    v: height 1024 start 1027 end 1034 total 1063           clock  59.89Hz

I have absolutely no idea what addmode would be adding to given that xrandr lists the mode already, but addmode just fails, and somehow the maximum is still 640x480. As you can see I'm writting from a ridiculously small resolution for a 21" screen.

I've been trying in vain to find a solution since I tried installing nvidia drivers, all the solutions failed me in one way or in another.

I'm using arch.

Update: nvidia-xconfig generates a conf file that makes the system unable to boot to the login screen. I have to delete it and run startx to get here. I guess the relevant part of Xorg.0.log about this would be:

  5570.962] (==) Matched vesa as autoconfigured driver 4
[  5570.962] (==) Assigned the driver to the xf86ConfigLayout
[  5570.962] (II) LoadModule: "nouveau"
[  5570.962] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  5570.991] (II) Module nouveau: vendor="X.Org Foundation"
[  5570.991]    compiled for 1.17.0, module version = 1.0.11
[  5570.991]    Module class: X.Org Video Driver
[  5570.991]    ABI class: X.Org Video Driver, version 19.0
[  5570.991] (II) LoadModule: "nv"
[  5570.992] (WW) Warning, couldn't open module nv
[  5570.992] (II) UnloadModule: "nv"
[  5570.992] (II) Unloading nv
[  5570.992] (EE) Failed to load module "nv" (module does not exist, 0)
[  5570.992] (II) LoadModule: "modesetting"
[  5570.992] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  5571.003] (II) Module modesetting: vendor="X.Org Foundation"
[  5571.003]    compiled for 1.17.1, module version = 1.17.1
[  5571.003]    Module class: X.Org Video Driver
[  5571.003]    ABI class: X.Org Video Driver, version 19.0
[  5571.003] (II) LoadModule: "fbdev"
[  5571.004] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  5571.014] (II) Module fbdev: vendor="X.Org Foundation"
[  5571.014]    compiled for 1.17.0, module version = 0.4.4
[  5571.014]    Module class: X.Org Video Driver
[  5571.014]    ABI class: X.Org Video Driver, version 19.0
[  5571.014] (II) LoadModule: "vesa"
[  5571.015] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  5571.023] (II) Module vesa: vendor="X.Org Foundation"
[  5571.024]    compiled for 1.17.0, module version = 2.3.2
[  5571.024]    Module class: X.Org Video Driver
[  5571.024]    ABI class: X.Org Video Driver, version 19.0
[  5571.024] (II) NOUVEAU driver 
[  5571.024] (II) NOUVEAU driver for NVIDIA chipset families :
[  5571.024]    RIVA TNT        (NV04)
[  5571.024]    RIVA TNT2       (NV05)
[  5571.024]    GeForce 256     (NV10)
[  5571.024]    GeForce 2       (NV11, NV15)
[  5571.024]    GeForce 4MX     (NV17, NV18)
[  5571.024]    GeForce 3       (NV20)
[  5571.024]    GeForce 4Ti     (NV25, NV28)
[  5571.024]    GeForce FX      (NV3x)
[  5571.024]    GeForce 6       (NV4x)
[  5571.024]    GeForce 7       (G7x)
[  5571.024]    GeForce 8       (G8x)
[  5571.024]    GeForce GTX 200 (NVA0)
[  5571.024]    GeForce GTX 400 (NVC0)
[  5571.024] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  5571.024] (II) FBDEV: driver for framebuffer: fbdev
[  5571.025] (II) VESA: driver for VESA chipsets: vesa
[  5571.025] (++) using VT number 2

[  5571.025] (--) controlling tty is VT number 2, auto-enabling KeepTty
[  5571.025] (EE) [drm] KMS not enabled
[  5571.025] (EE) open /dev/dri/card0: No such file or directory
[  5571.025] (WW) Falling back to old probe method for modesetting
[  5571.025] (EE) open /dev/dri/card0: No such file or directory
[  5571.025] (II) Loading sub module "fbdevhw"
[  5571.025] (II) LoadModule: "fbdevhw"
[  5571.025] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  5571.026] (II) Module fbdevhw: vendor="X.Org Foundation"
[  5571.026]    compiled for 1.17.1, module version = 0.0.2
[  5571.026]    ABI class: X.Org Video Driver, version 19.0
[  5571.026] (**) FBDEV(1): claimed PCI slot 0@0:13:0
[  5571.026] (II) FBDEV(1): using default device
[  5571.026] (WW) Falling back to old probe method for vesa
[  5571.026] (EE) Screen 0 deleted because of no matching config section.
[  5571.026] (II) UnloadModule: "modesetting"
[  5571.027] (II) FBDEV(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[  5571.027] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[  5571.027] (==) FBDEV(0): RGB weight 888
[  5571.027] (==) FBDEV(0): Default visual is TrueColor
[  5571.027] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[  5571.027] (II) FBDEV(0): hardware: VESA VGA (video memory: 1216kB)
[  5571.027] (II) FBDEV(0): checking modes against framebuffer device...
[  5571.027] (II) FBDEV(0): checking modes against monitor...
[  5571.027] (--) FBDEV(0): Virtual size is 640x480 (pitch 640)
[  5571.027] (**) FBDEV(0):  Built-in mode "current": 30.7 MHz, 36.9 kHz, 73.3 Hz
[  5571.027] (II) FBDEV(0): Modeline "current"x0.0   30.72  640 672 752 832  480 484 488 504 -hsync -vsync -csync (36.9 kHz b)
[  5571.027] (==) FBDEV(0): DPI set to (96, 96)
[  5571.027] (II) Loading sub module "fb"
[  5571.027] (II) LoadModule: "fb"
[  5571.027] (II) Loading /usr/lib/xorg/modules/libfb.so
[  5571.027] (II) Module fb: vendor="X.Org Foundation"
[  5571.027]    compiled for 1.17.1, module version = 1.0.0
[  5571.027]    ABI class: X.Org ANSI C Emulation, version 0.4
[  5571.027] (**) FBDEV(0): using shadow framebuffer
[  5571.027] (II) Loading sub module "shadow"
[  5571.027] (II) LoadModule: "shadow"
[  5571.027] (II) Loading /usr/lib/xorg/modules/libshadow.so
[  5571.028] (II) Module shadow: vendor="X.Org Foundation"
[  5571.028]    compiled for 1.17.1, module version = 1.1.0
[  5571.028]    ABI class: X.Org ANSI C Emulation, version 0.4
[  5571.028] (II) UnloadModule: "vesa"
[  5571.028] (II) Unloading vesa
[  5571.029] (==) Depth 24 pixmap format is 32 bpp
[  5571.029] (EE) FBDEV(0): FBIOBLANK: Invalid argument
[  5571.054] (==) FBDEV(0): Backing store enabled
[  5571.056] (==) FBDEV(0): DPMS enabled
[  5571.056] (==) RandR enabled
[  5571.066] (II) AIGLX: Screen 0 is not DRI2 capable
[  5571.066] (EE) AIGLX: reverting to software rendering
[  5571.654] (II) AIGLX: Loaded and initialized swrast
[  5571.654] (II) GLX: Initialized DRISWRAST GL provider for screen 0
[  5571.916] (II) config/udev: Adding input device Power Button (/dev/input/event5)

Also, running nvidia-settings gives me this error:

You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
0

Well, apparently this is what happens if you install the latest nvidia drivers instead of the ones you should. Totally counter-intuitive but it seems I needed the 304.xx and non of the newer others which I actually tried first worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.