11

I wanted to have some of the sub-folders of my home directory (like Music, Downloads,Videos) on my hard-disk-raid instead of my SSD. Therefore I deleted those folders in my home directory, recreated them on the RAID and made symlinks pointing from my home-folder to the RAID (e.g. /home/user/Music > /mnt/home-big-data/user/Music).

However, the newly created folders don't have the correct meta-data-properties in Gnome 3 (wrong icon, folders won't open as Music folder, etc.).

Which is the best way to remap those features to the folders on the RAID?

I tried editing the /home/user/.config/user-dirs.dirs and setting XDG_DOWNLOAD_DIR="$HOME/Downloads" (according to the symlink) but it was resetted to XDG_DOWNLOAD_DIR="$HOME/" after reboot.

Another thing I tried was using gvfs-set-attribute to reset the standard-icon, but this also failed.

Which would be the correct way to do that?

0

3 Answers 3

16

Most likely, your user-dirs are reset to $HOME/ each time you reboot because those locations are not available on session startup when xdg-user-dirs-update is automatically run.

After editing ~/.config/user-dirs.dirs a possible solution is to prevent xdg-user-dirs-update from running (and resetting your configuration at each session start up) by adding enabled=False to your user-dirs.conf:

    enabled=boolean
             When set to False, xdg-user-dirs-update will
             not change the XDG user dirs configuration.

So to disable it only for your user account, add enabled=False to ~/.config/user-dirs.conf (this will override system-wide settings). If you want to disable it for all users add that key/value to /etc/xdg/user-dirs.conf.

1
  • 1
    If the ~/.config/user-dirs.conf does not exists, simply create it with echo "enabled=False" > ~/.config/user-dirs.conf
    – Cyril N.
    Feb 10, 2017 at 15:33
3

Edit ~/.config/user-dirs.dirs, then run xdg-user-dirs-update.

5
  • I tried editing ~/.config/user-dirs.dirs and pointed to the symlinks (like XDG_DOWNLOAD_DIR="$HOME/Downloads" not to the "real" path /mnt/home-big-data/user/Downloads. I didn't run xdg-user-dirs-update but I rebooted the computer - the changes in ~/.config/user-dirs.dirs were reverted. Did I make a mistake (except not running xdg-user-dirs-update)? (I hope that's not a stupid question, I cannot try it at the moment as I'm not home)
    – Marcel
    Jun 3, 2015 at 9:27
  • 1
    @Marcel That depends on your particular OS. The relevant files are /etc/xdg/user-dirs.conf, /etc/xdg/user-dirs.defaults, and ~/.config/user-dirs.dirs. Perhaps there are man pages or HOWTOs about updating them on your OS.
    – lcd047
    Jun 3, 2015 at 11:02
  • it's Debian Stretch x64 with Gnome 3 desktop. Should be exactly as you stated...
    – Marcel
    Jun 3, 2015 at 11:08
  • hey @lcd047. I tried your solution (see above in my edited post, thank you), but sadly it didn't work... Do I have any other options to try?
    – Marcel
    Jun 4, 2015 at 0:41
  • @Marcel Like I said: your best option is to find docs that describe what you're supposed to do on (the right version of) your OS. I hopefully pointed you towards what to look for. I don't have Debian Linux, and I won't venture to guess blindly what contortions the Debian maintainers have come up with, sorry.
    – lcd047
    Jun 4, 2015 at 3:50
0

If anyone still has this issue, xdg-user-dirs-update --force will solve your woes.

1
  • Using "xdg-user-dirs-update --force" UNDID the changes I just made in my ~/.config/user-dirs.dirs file. I would instead like to make my changes to the user-dirs.dirs take effect, in File Manager, Firefox, etc.
    – MiloNC
    Apr 21, 2022 at 17:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .