2

I am using tmux on a Gentoo Linux hardened system running kernel 3.18.9. When I run programs that display borders on the terminal such as nmon directly under my terminal or under screen, they display fine.

nmon under screen

However, when I run such programs under tmux, the borders appear like Unicode error characters and some parts of the program output are mangled.

nmon under tmux

I've already tried setting different values for $TERM environment variable and it doesn't work. I can't figure out what does tmux have that somehow makes its terminal different from screen. What's happening here?

  • tmux inserts itself as a layer between whatever was running before and the programs it runs - probably a shell. It does this with a pty. It also interprets its own escapes and channels all i/o that is passed out above it - so it puts its fingers in all of your business. You'd do better with a more simple layer - tmux is a monster. Anyway, changing $TERM is not all you need - you'll also need to ensure that tmux supports all of the escapes and characters specified in its alternate character sets. The fact is, it just might not. – mikeserv Jun 3 '15 at 4:44
  • It is a TERM problem, it works fine here with xterm 318, tmux 1.9a, and TERM=xterm-screen-256color. However, xterm-screen-256color is a special termcap / terminfo entry that I had to install manually. Edit: here. – lcd047 Jun 3 '15 at 7:39
2

Just to share my experience. I did struggle today with tmux and linux mint 17 Border in tmux were not ok since last updates. (? i.s.o - or |) I tried lots of things without success.

What did solve my problem at the end: - go to setting -> Languages - set Language to English,United kingdom UTF-8 (or other UTF-8) - set Region to French-Belgium UTF-8 - then apply system-wide - and REBOOT linux !

After that problem with tmux was gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.