I'm having issues with dropbox so I'd like to uninstall and reinstall it. To do so I need to remove ~/.dropbox-dist but no matter what I do it won't budge. If I run ls -l I get:

drwxr-xr-x   3 user user     4096 Nov 13  2014 .dropbox-dist

I have full permissions on the machine.

I have tried,

  1. sudo rm -rf ~/.dropbox-dist
  2. rm -rvf ~/.dropbox-dist
  3. sudo su, rm -rf /home/user/.dropbox-dist
  4. Removing from Nautilus
  5. chmod 777 ~/.dropbox-dist

But the error is always the same, "Operation not permitted"

  • Check if you have some dropbox software run – Romeo Ninov Jun 2 '15 at 17:45
  • Running top I don't see anything with the preface "dropbox", nor do I see anything in gnome-system-manager. So unless dropbox uses an alias I don't think anything is running – JeffDror Jun 2 '15 at 17:52
  • Try: lsof | grep .dropbox-dist and see if there are any results that way. – SailorCire Jun 2 '15 at 17:54
  • @SailorCire: I'm not sure what this does, but the output is : bash 31734 user cwd DIR 8,6 4096 4227377 /home/user/.dropbox-dist/dropbox-lnx.x86_64-2.10.52 – JeffDror Jun 2 '15 at 17:56
  • 1
    user is currently in a directory called /home/user/.dropbox-dist/dropbox-lnx.x86_64-2.10.52 and is running bash with a process ID of 31734. Tell user to cd out of that directory and then try removing it. If that doesn't work, find the process and kill it, but that might cause very bad side effects. – SailorCire Jun 2 '15 at 18:02

There are few things you could do here:

  1. First check whether you have a Dropbox daemon running.
  2. Check the attributes of the Dropbox folder using lsattr and if the folder is not editable, then change its attributes to editable using chattr.


As OP has reported in the comments, the .dropbox-dist folder contains i attribute which means the folder cannot be modified, deleted or renamed. Hence to change the attrubute, you should use chattr:

sudo  chattr =e .dropbox-dist
  • Thanks for your answer. Checking attributes I find it has the attributes: "----i--------e--" – JeffDror Jun 2 '15 at 17:57
  • 1
    That's good. Attribute i means it can not be modified. So, now you can change the attribute and remove the i using chattr, and the folder would be modifiable then. Use chattr =e .dropbox-dist. – shivams Jun 2 '15 at 17:59
  • 1
    This works, thanks for your response. I didn't even know attributes existed... – JeffDror Jun 2 '15 at 18:22
  • 1
    Thanks for finding the chattr. I was able to do sudo chattr -R =e <stubborn file directory> and then was able to get rid of the directory which otherwise wouldn't go away due to these (hidden) attributes. – Phil Ryan Oct 8 '18 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.