1

I'm trying to remotely install CentOS 7 (using the "Everything ISO" from official download page) on an IBM server with IMM2 (Integrated Management Module 2) using the Remote Control single-user mode with Java Client facility. The IBM server machine is a brand new one, with no operating system installed on it. The hardware is ok.

The install gets stuck on this:

enter image description here

And then I lose the connection to the server (Error: The viewer has terminated. Reason: Connection has ended), java applet crushes (Error: Socket Closed by peer reading header.) and the ISO is unmounted.

If i establish the remote connection, the system is still stuck on the what you see in the image above, so I try to change the terminal to tty2, and it works but all I can do (from what i've figured so far) is give commands like "mount", "dmesg", "anaconda" (dmesg shows lots of errors; i don't know what anaconda application does) and change the directory - "cd".

dmesg output sample

I've tried to find a way to install CentOS in Text Mode (like I know I can in ArchLinux and DSL) because i thought it has something to do with loading the video module or something like that, but i can't find a way to make that work with CentOS...

I have tried to install "Damn Small Linux" (DSL) distribution on this server in the same manner as CentOS 7 and it worked.

I have tried to modify the CentOS bootloader command to force it to take another network interface (the server has 2 network interfaces active and I've suspected that it kills one of them and that is why i lose the connection) Can you please help me find a way to make this CentOS 7 install work in this conditions? Do you have any other solution to make this work, besides with an actual trip to the physical machine with a dvd/usb stick with the system on it?

PS: I have just discovered that on tty4 I get this errors that appear continuously:

enter image description here (I'm restarting now...) I really hope someone can help me or can give me a hint or new ideea! Thank you!

1

I've no experience with the IMM2, but under the basic IMM, I also had this problem. What I did find though - if you re-mount the ISO when it first unmounts, and then later when the whole java KVM client seems to crash - you will notice the data read counter for the mounted ISO keeps on going. This is because only the KVM portion crashes. If you don't touch the 'Ok' on the error message, but instead go to another computer and fire up a second IMM KVM session - the installer will be there and waiting for you to continue. Just DO NOT close out the error on the first instance, as that one (despite being crashed) is still providing the VirtualMedia pipe. Also, you may have to change a setting in your IMM to avoid it accepting USB control commands - set "Allow commands on USB interface" to "Disabled" to avoid the install bombing out even earlier.

  • Thank you! Next time I run into this problem I'll surely try this. – Andreea Jul 5 '18 at 12:13
0

The fact that you're installing via IMM is unrelated, you'd be seeing the same if installing locally.

You seem to be having I/O errors on your dm-0 filesystem, often indicating hw issues with the device holding it. If so you'd have to get the defective hw replaced.

It's also possible to be a just a corrupted partition - if you're re-using it without formatting it at installation, in which case it might work if you do chose to format it (careful - that means losing all data on it, you'd need to repair the filesystem and then save whatever you need from it first).

  • Thank you so much for you response! In essence you are right but I don't think those are the problems in this case. I've added some disambiguation to my previous post. The I/O error was because the IMM2 Remote Connection was lost and no ISO was mounted anymore. – Andreea Jun 2 '15 at 15:53
  • Hm, I disagree - those are write errors and the installation doesn't write to the installation ISO, it's only writing to the installed system's partitions. Also the errors are ext4 FS errors, the ISO doesn't have an ext4 FS. – Dan Cornilescu Jun 2 '15 at 15:59
  • The ISO is mounted on a virtual disk (is a live DVD) and the system sees it as a "normal"/physical ext4 one. When the network connection is lost the disk is unmounted and that error occurs as if it was thrown for a normal one. – Andreea Jun 3 '15 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.