4

I use Trisquel 7.0 LTS (Comes with GNOME 3 Flashback). I visited some post like this and this. on the topic about adding custom compose key sequence.

I set Menu Key as Compose Key:

screenshot

I created ~/.Xcompose containing:

$ cat ~/.Xcompose 
include "%L"   # import the default Compose file for your locale
<Multi_key> <r> <r>     : "ñ" U00F1

Also added export GTK_IM_MODULE="xim" at the end of ~/.profile. I tried after logging out and login back, also restarting many times but it is not working.

The default compose key sequences (/usr/share/X11/locale/en_US.UTF-8/Compose) e.g. Menu, s, s = ß is working fine.

I also tried to add custom key sequence:-

<Multi_key> <s> <d>                 : "ñ"   U00F1

At the end of /usr/share/X11/locale/en_US.UTF-8/Compose but it is also not working.

Thus, Why my custom compose sequence is not working? What am I missing?

EDIT:

I've installed uim and set GTK_IM_MODULE="uim" instead of xim by export GTK_IM_MODULE="uim" at ~/.profile after restarting session, I found that Manually set custom key sequence in /usr/share/X11/locale/en_US.UTF-8/Compose is working now. BUT still defined sequence in ~/.Xcompose is not working.

BTW, what is xim and uim relation to input method and why uim is working and xim is not in my case?

closed as off-topic by Pandya, Gilles, MelBurslan, Jeff Schaller, Archemar Mar 24 '16 at 16:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Pandya, Gilles, MelBurslan, Jeff Schaller, Archemar
If this question can be reworded to fit the rules in the help center, please edit the question.

3

It was my mistake that I created .Xcompose instead of .XCompose! (see question that every times mentions .Xcompose).

Now all custom compose key sequences that are defined in ~/.XCompose are working well.

Not the answer you're looking for? Browse other questions tagged or ask your own question.