3

I already have a production version of GPG from a previous installation.

I would like to build and test the last version of GPG without interfering with the production one. I am performing this test on MacOS X 10.10.3, but ideally this validation process should be independent of the OS.

I created a new repository directory different of the one where the running GPG is:

mkdir /local/gpg2

I downloaded the 4 required libraries and the gnupg archive:

libgpg-error-1.19
libgcrypt-1.6.3
libksba-1.3.3
libassuan-2.2.1
gnupg-2.0.27

I successfully built and installed libgpg-error:

cd libgpg-error-1.19
./configure --prefix=/local/gpg2
make
make install

and started to build libgcrypt:

cd ../libgcrypt-1.6.3
./configure --prefix=/local/gpg2

and this process fails with:

checking for gpg-error-config... no
checking for GPG Error - version >= 1.11... no
configure: error: libgpg-error is needed.
                See ftp://ftp.gnupg.org/gcrypt/libgpg-error/ .

I checked config.log where:

exec_prefix=NONE
prefix='/local/gpg2'
libdir='${exec_prefix}/lib'

and everything seems correct.


Where is this configuration problem coming from?

0

1 Answer 1

2

Since you're installing in non-standard locations, you'll need to tell each configure script where to find things. ./configure --help should give an indication of the appropriate option; for libgcrypt you'd run

./configure --prefix=/local/gpg2 --with-libgpg-error-prefix=/local/gpg2

Except that because of a bug in libgcrypt's configure script, only --with-gpg-error-prefix works, so you need to run

./configure --prefix=/local/gpg2 --with-gpg-error-prefix=/local/gpg2

The bug is already fixed in upstream's repository; it's #1467.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.