0

I have an installation of Arch on an ext4 partition on a 250GB SSD. My intention was to copy the partition containing it to a different HD on my system, and resize the copy. So from a separate Ubuntu partition mounted on yet another drive, I copied the partition using gparted.

This seemed to work fine, and so just to make sure the copy worked, I tried booting to the newly copied partition. During the boot process, this hung (and still hangs) before GDM starts, with the bootup text flashing off and on. When I ctrl+f4, e.g., I could see a login prompt, but the flashing text continued, making it impossible to log in. So I tried to reboot to my original SSD Arch partition.

Strangely, the Arch installation on the original partition mounted /dev/sdc1 (the copied partition) as /, instead of /dev/sda1 (the ssd). Other than that it seemed to boot OK. When I look at my /etc/fstab in both the original and the copied partition, it still points /dev/sda1 to /, as it did before.

The UUID of the original and copied partition are the same, but the partuuid given by blkid looked like PARTUUID="000118d6-01", and was different for each. But setting up the mountpoint in fstab using that partuuid in place of /dev/sdc1 (for the copy partition) still results in the hung boot.

How could the mount point have been modified like that, and how do I fix my original Arch installation to mount /dev/sda1 on boot, as before?

0

I discovered that the grub2 boot commands for my Arch partition look for the UUID in order to figure out which partition to mount.

So, the fix is, use gparted to change the partition UUID of the copied partition, and the original Arch partition works as before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.