3

In localhost:631/printers in the "Make and model" column, CUPS correctly identifies my printer as:

HP LaserJet 2100 - CUPS+Gutenprint v5.2.10

This is what I want to get printed:

What I want

Here is roughly how the printout looks:

enter image description here

The document is scaled and aligned to the left and top.

I tried fiddling with settings in the sytem printing dialog, but nothing helped. I tried printing without the system dialog, using lpr utility — same result.

However, if I print a test page, it prints out perfectly without upscaling.

How can I fix this scaling issue?

  • Do you have a problem with only a few documents, or with all documents? If it's only with some documents, can you share one? – Gilles 'SO- stop being evil' Jun 1 '15 at 22:26
  • @Gilles With all of them. I tried printing various .doc, .ps and .xls files. – jojman Jun 1 '15 at 23:31
3

I had a similar problem and found it useful to turn off cups printer option fitplot as follows (these are instructions for Linux Mint 17, but should work for similar distributions.)

Open a terminal and edit the printer.conf file.

sudo vi /etc/cups/printer.conf

find the line that contains Option fitplot True

and change that line to now contain Option fitplot False

now save the file which you have just edited.

Now restart cupsd via command

sudo service cups restart
0

I had the same problem: PDF document seemed scaled out and not fitting on the A4 page provided by my printer HP Deskjet 3050.

Solution:

Add (or change) the option fitplot to True:

#/etc/cups/printers.conf
<Printer Deskjet_3050>
    ...
    Option fitplot True
    ...
</Printer>

According to the manual a value of True scaled the document to fit the page. By default the size of the document is used for scaling. But the manual warns that "If no size is given in the file, the page may be scaled incorrectly!". So that might be the reason for our initially wrong scaling - no sizing within the document.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.