0

I am trying to install two node cluster for web server.

We have super mico hardware HA BOX. It has 5 disk. one disk is used for node1 os installation and another disk is for node2 OS. Remaining disk is for quorum and shared storage.

My problem is in node 1 it is detected as a /dev/sda and in node 2 it is detected has /dev/sdf but uuid is same for both the devices.

Node1 lsblk output

sdg 8:96 0 3.8G 0 disk

sdb 8:16 0 34.2G 0 disk

├─sdb1 8:17 0 512M 0 part

├─sdb2 8:18 0 29.3G 0 part

└─sdb3 8:19 0 4.4G 0 part

sdd 8:48 0 34.2G 0 disk

├─sdd1 8:49 0 512M 0 part /boot

└─sdd2 8:50 0 29.3G 0 part /

sde 8:64 0 34.2G 0 disk

└─mpathc (dm-3) 253:3 0 34.2G 0 mpath

sdf 8:80 0 68.4G 0 disk

└─sdf1 8:81 0 68.4G 0 part

└─nfs-lvnfs (dm-1) 253:1 0 50G 0 lvm

sda 8:0 0 137G 0 disk

└─mpathe (dm-0) 253:0 0 137G 0 mpath

└─mpathep1 (dm-7) 253:7 0 137G 0 part

node2 lsblk output

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT

sdg 8:96 0 3.8G 0 disk

sda 8:0 0 34.2G 0 disk

├─sda1 8:1 0 512M 0 part /boot

├─sda2 8:2 0 29.3G 0 part /

└─sda3 8:3 0 4.4G 0 part /swap

sdc 8:32 0 34.2G 0 disk

├─sdc1 8:33 0 512M 0 part

└─sdc2 8:34 0 29.3G 0 part

sdd 8:48 0 34.2G 0 disk

└─mpathb (dm-1) 253:1 0 34.2G 0 mpath

sde 8:64 0 68.4G 0 disk

└─sde1 8:65 0 68.4G 0 part

sdf 8:80 0 137G 0 disk

└─mpathd (dm-3) 253:3 0 137G 0 mpath

└─mpathdp1 (dm-8) 253:8 0 137G 0 part

sr0 11:0 1 1024M 0 rom

blkid in node1

/dev/sdd2: UUID="69480877-c022-48af-8534-a3f91a587805" TYPE="ext4"

/dev/sdb1: UUID="a59262f8-b37b-4c50-ba13-bbfb928f4fca" TYPE="ext4"

/dev/sdb2: UUID="c6741a56-5b4d-4061-a20b-71f4c4d348ac" TYPE="ext4"

/dev/sdb3: UUID="ee654c6e-232c-4b1b-bcda-233502dcce31" TYPE="ext4"

/dev/sdd1: UUID="06f5a70b-135a-4e3b-8945-f7747fd5c133" TYPE="ext4"

/dev/sdf1: UUID="GtrjBM-P2U9-VFcK-yvwd-JTmZ-1esg-dM3MZT" TYPE="LVM2_member"

/dev/mapper/mpathbp1: UUID="a59262f8-b37b-4c50-ba13-bbfb928f4fca" TYPE="ext4"

/dev/mapper/mpathbp2: UUID="c6741a56-5b4d-4061-a20b-71f4c4d348ac" TYPE="ext4"

/dev/mapper/mpathbp3: UUID="ee654c6e-232c-4b1b-bcda-233502dcce31" TYPE="ext4"

/dev/mapper/mpathep1: UUID="f6a58cf7-b39b-489c-add5-444ceab8af9d" TYPE="ext4"

blkid in node2

[root@simha2 ~]# blkid

/dev/sda2: UUID="c6741a56-5b4d-4061-a20b-71f4c4d348ac" TYPE="ext4"

/dev/sda1: UUID="a59262f8-b37b-4c50-ba13-bbfb928f4fca" TYPE="ext4"

/dev/sda3: UUID="ee654c6e-232c-4b1b-bcda-233502dcce31" TYPE="ext4"

/dev/sdc1: UUID="06f5a70b-135a-4e3b-8945-f7747fd5c133" TYPE="ext4"

/dev/sdc2: UUID="69480877-c022-48af-8534-a3f91a587805" TYPE="ext4"

/dev/sde1: UUID="GtrjBM-P2U9-VFcK-yvwd-JTmZ-1esg-dM3MZT" TYPE="LVM2_member"

/dev/mapper/mpathcp1: UUID="GtrjBM-P2U9-VFcK-yvwd-JTmZ-1esg-dM3MZT"

TYPE="LVM2_member"

/dev/mapper/mpathap1: UUID="06f5a70b-135a-4e3b-8945-f7747fd5c133" TYPE="ext4"

/dev/mapper/mpathap2: UUID="69480877-c022-48af-8534-a3f91a587805" TYPE="ext4"

/dev/mapper/mpathdp1: UUID="f6a58cf7-b39b-489c-add5-444ceab8af9d" TYPE="ext4"

I want use uuid of UUID="f6a58cf7-b39b-489c-add5-444ceab8af9d" in cluster.

In luci web console under resource tab i have given above uuid to autodetect and mount files system in both the nodes since we can use Device, FS Label, or UUID. I given UUID .

I am starting service group in luci console i am getting error could't start clusvcadm .

Below is rgmanger.log

May 31 16:53:29 rgmanager Reconfiguring May 31 16:53:29 rgmanager Loading Service Data

May 31 16:53:31 rgmanager Stopping changed resources.

May 31 16:53:31 rgmanager Restarting changed resources.

May 31 16:53:31 rgmanager Starting changed resources.

May 31 16:54:10 rgmanager Stopping service service:Web directory

May 31 16:54:10 rgmanager [fs] stop: Could not match "f6a58cf7-b39b-489c-

add5-444ceab8af9d" with a real device

May 31 16:54:10 rgmanager Service service:Web directory is disabled

May 31 16:54:11 rgmanager [fs] start_filesystem: Could not match "f6a58cf7-

b39b-489c-add5-444ceab8af9d" with a real device

May 31 16:54:14 rgmanager [fs] start_filesystem: Could not match "f6a58cf7-

b39b-489c-add5-444ceab8af9d" with a real device

May 31 16:54:17 rgmanager [fs] start_filesystem: Could not match "f6a58cf7-

b39b-489c-add5-444ceab8af9d" with a real device

May 31 16:54:20 rgmanager start on fs "Web document root" returned 2

(invalid argument(s))

May 31 16:54:20 rgmanager #68: Failed to start service:Web directory; return

value: 1

May 31 16:54:20 rgmanager Stopping service service:Web directory

May 31 16:54:20 rgmanager [fs] stop: Could not match "f6a58cf7-b39b-489c-

add5-444ceab8af9d" with a real device

May 31 16:54:20 rgmanager stop on fs "Web document root" returned 5 (program

not installed)

May 31 16:54:20 rgmanager #12: RG service:Web directory failed to stop;

intervention required

May 31 16:54:20 rgmanager Service service:Web directory is failed

May 31 16:54:20 rgmanager #2: Service service:Web directory returned failure

code. Last Owner: simha1

May 31 16:54:20 rgmanager #4: Administrator intervention required.

Attached cluster screen shot for reference.

Even i tried with assigning label name to filesystem not working and also i tried with filesystem mount like /dev/mapper/mpathep1 then it is working for node1 and when i trun off node1 is not starting since /dev/mapper/mpathep1 is not present in node

Os Redhat 6.5.

Please help me

  • Please read the formatting guide, and edit your post accordingly. – lcd047 Jun 1 '15 at 6:16
  • I have changed itt – sagar Jun 2 '15 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.