0

I'm getting this error after rebooting:

Scanning for Btrfs filesystems
 * Stopping Read required files in advance                         [ OK ]
 * Starting Mount filesystems on boot                              [fail]

    screenshot of error messages

I tried the instructions here: Ubuntu 13.04 to 13.10: Filesystem check or mount failed (in summary: remount root read/write, run dpkg --configure -a, remount root read-only, and reboot), and no dice. I also found a thread about getting rid of Btrfs (How to get rid of the “scanning for btrfs file systems” at start-up?), but I'm not sure if that's a good idea to try.

This is all on a Virtual Machine and I do have a snapshot before I shutdown the system, that seems to be working. But it's going to be a problem if I can never shut down.

  • So I did try deleting btrfs but no success. I've tried using a live cd to access Rescue Broken System but I don't have that option? I suspect the issue is a corrupt locale file. – Veta Jun 1 '15 at 0:45
0

I'm not sure if your system was installed to use Btrfs for its primary filesystem, but it sounds like it. The only way to change it to something else, is to create new partitions with a different format and copy/restore the files on the new partition. An external USB drive or a large enough flash drive would work for this.

(Side note: this is why experimental filesystems shouldn't be used for critical data. :))

IIRC, you can still boot to a shell prompt in Ubuntu by adding the letter "S" or the word "single" to the end of the boot command in GRUB (or GRUB2). Doing so will get you to a command prompt in which the filesystems have not yet been mounted. You can do your fsck's and related diagnostics from there. Reboot when your done to see if your machinations have solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.