3

I was able to create a wifi hotspot on my debian 8 install using network tab under gnome settings. I was trying to do the same using nmcli but it always shows

$nmcli con up id Hotspot

Error: Connection activation failed.

I'm trying to connect to the connection created by gnome itself.

$nmcli connection show

Hotspot 6db9bb0a-c61b-47fc-8ada-7ecd46873fc0 802-11-wireless --

I followed the steps from here.

  • Welcome to Stackexchange! On my machine, I need to run nmcli con up id with sudo. Maybe that helps. – nhee May 30 '15 at 8:29
  • @nhee tried, but the same error. – letmutx May 30 '15 at 16:45
  • Sorry, no idea then. – nhee May 30 '15 at 19:35
0

I encountered this on Arch Linux 4.19.2 because wpa_supplicant and dhcpcd were running on my system.

The fix in my case was to end those programs and restart NetworkManager:

sudo pkill wpa_supplicant && sudo pkill dhcpcd
sudo systemctl restart NetworkManager.service

After that, I can connect again:

nmcli con up id myNetwork

The complete error message was

Error: Connection activation failed: No suitable device found for this connection (device wlp3s0 not available because device is not available).

I think wicd also interferes with NetworkManager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.