3

I have an Asus EeeBook X205TA which proves very difficult to install Linux on due to obscure new hardware and 32-bit EFI on 64-bit hardware. I have seen and read a lot of material and I am almost finished. The problem I have now is as follows:

When I boot the system I always get the grub> prompt where I can enter what is written in /boot/grub/grub.conf which will work:

insmod gzio
insmod part_gpt
insmod btrfs
linux  (hd0,gpt5)/@/boot/vmlinuz-3.19.0-18-generic.efi.signed root=LABEL=UNIXROOT rootflags=subvol=@
initrd (hd0,gpt5)/@/boot/initrd.img-3.19.0-18-generic

How do I fix the problem that grub (2.02~beta2) apparently does not find /boot in the subvol @ of the btrfs partition LABEL=UNIXROOT? I have played with efiboot, which has 2 relevant entries now, ubuntu and Linux, one of which gets me to grub>, the other to grub rescue>. How can I get information from grub2 why it fails? grub-update does not change a thing.

The problem is that I do not know how booting works with EFI ->?-> GRUB ->?-> FS->/boot/grub/grub.cfg, so all my efforts are blind.

What do you need to know? Ubutu 15.04 64-bit, 32-bit UEFI, 32GB eMMC, Z3735 baytrail CPU, Win 8.1 still alive, Secure Boot disabled, Legacy Boot not a BIOS option, what else?

  • I'd rather not start with complicating every bit I can -- that is, wouldn't stick btrfs (or lvm, or whatever) under /boot at the very least on an EeePC... have you read rodsbooks.com/efi-bootloaders/principles.html already? – Michael Shigorin May 30 '15 at 7:31
  • 1
    Dear Michael, You are probably right. I knew that btrfs has advantages over ext4 for SSDs, and I wanted to enable compression because of the small disk (7GB Linux partition including home!). What I did not know was how badly the Ubuntu installaller can handle btrfs - it has created subvolumes without asking me, and is has no option to enable compression. openSUSE's installer is much better in this respect. – Ned64 May 30 '15 at 12:37
  • I have shrunk the btrfs and created a separate ext4 boot partition. It has not helped. – Ned64 May 30 '15 at 22:30
  • Well then Rod's books on EFI are the way to go -- sorry but I've dropped 64-on-32fw experiments last year due to availability of optional 64-bit firmware for my device so no experience-based hints came my way so far... – Michael Shigorin May 31 '15 at 13:12
2

I've been working with a similar issue all day. I just installed lubuntu on a Quantum Byte QS-1043-QB. It uses the same processor and chipset you are working with. I got the to same point you are.

Basically, you need to install a 32 bit EFI file for grub and 32 bit grub version.

First, install 32-bit support for grub

sudo apt-get install grub-efi-ia32 grub-efi-ia32-bin

By default, grub is installing a 64 bit EFI, which will not work with the UEFI system on our PCs. I compiled as 32 bit grub EFI on my laptop, then copied it over to the Quantum Byte. I uploaded that EFI file here: grubia32.efi

I then copied that EFI file over the default grub 64 bit version (do as root):

mkdir /boot/efi/EFI
mkdir /boot/efi/EFI/ubuntu
cp grubia32.efi /boot/efi/EFI/ubuntu/grubx64.efi

Update the grub configuration (again, do as root):

update-grub
update-grub2

At this point, you can reboot and see if it works. You may get lucky. I rebooted, then got dumped to the grub command line. I entered this to tell grub where the config file is:

configfile (hd0,gpt2)/boot/grub/grub.cfg

And the system entered the grub boot menu, but it was all gibberish. After starting up, I updated the grub config file to enable the text based menu and then reinstalled grub to fix the configfile location issue:

sudo nano /etc/default/grub

Uncomment: GRUB_TERMINAL="console" Type Ctl-X and hit Y to save.

Reinstall grub:

sudo grub-install

I rebooted and now everything seems swell! Hope it works for you, good luck.

  • 1
    Thanks very much for this. This is indeed useful information for the installation of Linux on Baytrail-based computers. However, it does not quite answer the question I had (which I have since solved, I will enter the reply here for others when I have the time). – Ned64 Jul 13 '15 at 18:41
  • Ned64, you are right, I did not address your original question, apologies. – toomuchtv Jul 14 '15 at 22:53
  • Also, I just installed linux mint on this same machine. The process was much easier. After the initial install, I simply ran the commands to install grub 32 bit, updated grub, and did the reinstall. Machine seems to work no problem. Maybe the original was over complicated. – toomuchtv Jul 14 '15 at 22:54
  • 1
    @Ned64 please share your knowledge – Aleksandr Dubinsky Nov 16 '15 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.