4

I just now installed Cent OS 7 on my VMware 8 and I am not able to connect it to a network.

I checked the VM network and its mapped to the physical NIC. The same setting work like charm on my CentOS 5 running on VM8.

Running the ip a command shows the following output:

ip output

  • Forgot to mention i didnt find resolve.conf file on the system too (Read an article suggestion issues with resolve.conf so tried looking it up and it was missing ) – Atul May 28 '15 at 23:58
  • So when you get out of full screen when you click on the network cable icon on the bottom right and click preferences, what kind of connection you have there? – VaTo May 29 '15 at 2:31
  • What kind of system r u using 32-bit or 64-bit? centos7 is basically designed to work on a 64-bit system. If 32-bit system, while installing on vmware try installing using centos as 64-bit then u wont find any network issues. – user117244 May 29 '15 at 5:19
  • I have tried briged and NAT both and had no luck. The NAT works fine on my other machine ie CentOS 5 – Atul May 29 '15 at 6:41
  • When you created the VM and it asked what kind of OS was to be installed did you select Linux or windows? If created as a "Windows" VM you'll get a different NIC type that may not work, and it's a hassle to change after the fact (you can't change it through the GUI). – Centimane Sep 22 '16 at 13:33
9

You have to activate the interface. One way of doing that is with Network Manager's utility nmtui.

Open nmtui with:

$ sudo nmtui

And you'll get a text based interface like this:

enter image description here

Navigate by using TAB and ENTER.

In nmtui you can activate your interface, edit connection's and set hostname.

After you're done, restart network with:

$ sudo systemctl restart network
  • 1
    I tried configuring the wifi connection hoping it will connect to my wifi and get on the network however it did nothing. Ip a shows no interface again. Should i be selecting a different connection type? – Atul May 29 '15 at 6:38
  • @Krt sudo nmtui and then activate connection is working for me. But whenever I power off the VM the configuration is gone. Is there a way to make it permanent. – Vikash Feb 8 '18 at 9:33
  • Should be marked as valid answer – 1020rpz Nov 2 '18 at 8:17
1

I user bridged network,you should attach your guest OS's network interface to host interface,you need edit vmware's network editor:

Edit ->  Virtual Network Editor -> bridged to host interface

picture:

enter image description here

0

Open my.vmx which contain your VM configurations and Added the following line to my.vmx:

ethernet0.virtualDev = "e1000"

My problem was solved by this line.

0

In the nmtui, edit the connection and then select Automatically Connect check box. Restart the network and you should be back in business :-)

0

I had a similar issue with a VM running Red Hat Enterprise Linux (RHEL) V6.4 with VMWare 10. I was able to fix it using the "Restore Defaults" button in VMWare's Virtual Network Editor. In my case, somehow the bridged network had been deleted at some time in the past.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.