2

Well, my problem is very complicated, I've an old machine (Dell Vostro 1000) where I'm using Debian 8 with XFCE. This machine have an integrated video card (ATI MOBILITY RADEON XPRESS 200 - Model: 1150), and it doesn't work with Debian default configuration.

Let's see what I already have tried:

  • To turn on my laptop without it shows the notorious colored stripes I need use the "nomodeset" code on grub.cfg.
  • The Debian 8 appears don't have the xorg.conf (???), I made a Xorg.conf following the instructions at https://wiki.debian.org/AtiHowTo , without success.
  • I tried already tried follow the procedures in the page above, cause the current proprietary driver is not compatible with my old video card. and the older version (legacy) can't be installed and shows some conflicts with "X". This way I have to use the generic linux driver.
  • I tried set the display resolution using XRANDR, but it fails and when I made the insertion of another resolution, I just can't select this.
  • Thinking about modules, maybe I can see a little ligth in the end of tunnel. I find a blacklist file into "/etc/modprobe.d" and removed the module "radeonfb" of blacklist, but when I tried to restart, the machine only shows a black screen with the mouse pointer only. to fix this I changed the "quiet" entry of boot line and changed it with "single" to show the command line and I can see that when the module "radeonfb" is loaded, the letters of command line become small (like it have made a resolution adjustment) but I need understand why only a black screen and the mouse pointer is showed.

NOTE: The xorgs and firmware-linux are installed but doesn't work. I really don't need 3d acceleration, but I need to resize my screen. Actually it's 1024x768 but the hardware can show 1280x800.

0

I'm sorry that actually there is no way you can have hardware acceleration with an old ATi GPU. But you can have some acceleration with the open source driver (I guess it'd need a non-free firmware, is there any problem reported at boot, if yes try install firmware-linux).

And thanks to llvmpipe, you still have 3d acceleration (rendered via software, of course), and I think it wouldn't be a problem if you have a fast CPU.

  • @Diego Sorry I need to post the comment here, but is there any missing firmware reported at boot? I also use a old ATi GPU (a Rv280) and same monitor size wit you on Debian testing, everything goes fine after I install firmware-linux-nonfree. And try out if this help: wiki.ubuntu.com/X/Config/… And stupid question but have you try the xfce Display setting? – McSinyx May 29 '15 at 11:21
  • No problems. in the boot, just appears this error: "[drm:radeon_init] ERROR No UMS support in radeon module!" . firmware-linux-nonfree are installed too, and I tried the display config and the method on the link you send me (using XrandR). But now I have Some good news here. I just discovered that when I remove the module "radeonfb" from "devfb-blacklist.conf", the SO only shows the mouse pointer in a black screen (ok, no news until here), but when I made that and boot in safe mode, the resolution is okay. :D Now, what I need to uninstall? what is conflicting? – Diego May 29 '15 at 12:06
  • Have you enabled display compositing (xfwm4-tweaks-settings, tab Compositor)? – McSinyx May 29 '15 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.