1

I have found only one discussion about my problem here, but not a solution.

I have access to one Debian 7.8.0 amd64 virtual machine (under VMware) and its IP address is gained through DHCP, e.g., 192.168.0.90 (gateway 192.168.0.121).

To obtain a static IP I configure /etc/network/interfaces like this:

auto eth0
iface eth0 inet static
    address 192.168.0.10
    netmask 255.255.255.0
    gateway 192.168.0.121

Then I run ifdown eth0 && ifup eth0 and everything works for hour or two (from ifconfig I see 192.168.0.10). After that time I see with ifconfig that my IP has changed automatically to 192.168.0.90 (the old one obtained from DHCP).

Why is this happening?

I tried to execute /etc/init.d/networking restart, but it says that It is deprecated because it may not enable some interfaces... and my eth0 goes away and does not show up in ifconfig anymore (I need to run ifup eth0 to bring it up again).

Noone in the network is using x.x.x.10.

4
  • 1
    ifconfig -a to see unenabled interfaces
    – Skaperen
    May 27 '15 at 12:23
  • 2
    Do you have a dhclient process running? Please check the result of ps -ef |grep dhclient.
    – Lambert
    May 27 '15 at 12:55
  • Yes, I have dhclient running... Now I will try to kill (or go with remove) to try and I will post the results. Thank you for your comments, people!
    – user63431
    May 27 '15 at 12:57
  • Okay, thank you very much again - killing dhclient solved the problem!
    – user63431
    May 28 '15 at 8:54
1

Maybe you should set your statics IP in the DHCP server or in the router (it could work as DHCP server). Check this tutorial.
There are some considerations about setting a static IP in the client or in the DHCP server. Take a look to this.

1
  • Yes, this surely solves the problem - when IP is set as static in the DHCP server (in the router in my case). Now I am trying by stopping dhclient to see what is going to happen when changing the IP from the client. Thank you!
    – user63431
    May 27 '15 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy