4

Upon boot GDM3 is correctly started but hangs at the splash screen and no GUI login box appears. The only way to log into the system and graphical interface is following these steps:

  1. CTRL+ALT+F1
  2. logging in
  3. sudo /etc/init.d/gdm3 stop && startx

What could be broken?

I tried dpkg-reconfigure gdm3 to no avail... Also, grep EE etc/X11/xorg.conf doesn't return any error.

  • Could you post you logs ? tail -n 30 /var/log/Xorg.0.log – Rémi B. May 27 '15 at 10:13
2

UPDATE

I found a workaround after reading these bug reports: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=785782 and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=724731

In my case the workaround was installing lightdm as display manager. sudo aptitude install lightdm This also prompts you to choose it as default display manager.

However this still doesn't solve the apparent bug in gdm3...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.