1

I use a custom keyboard with a “REPL” key (shifted: “Settings”) that I have bound to XF86Send (shifted: XF86Tools). On Fedora 21, that key (XF86Send) somehow works to toggle the “mute” on this laptop's internal microphone. I get the same kind of symbol-on-black-glass as the “normal” volume keys, and the Sound panel in Settings shows the toggle switch moving (Settings → Sound → Input → Input Volume → On/Off). However, unlike the volume up/down/mute keys, there doesn't seem to be a place to rebind this key in Settings → Keyboard → Shortcuts → Sound and Media (nor anywhere else that I've checked).

This prevents the key from appearing to applications (eg I have it bound to bring up a REPL or similar sessions in Emacs for various languages). xev shows some line noise, but no real keystroke, and <Help> k <XF86Send> in Emacs never gets the REPL/Send keystroke (it still awaits with Describe key (or click menu):)

  • Is this a part of the Gnome Shell, or some other coöperating program?

Or, more significantly:

  • Can I remove this binding, maybe via dconf editing or something?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.