2

I recently bought a new computer and I am experiencing problems while trying to install Linux.

Things I have tried:

A variety of distributions:

  • Ubuntu;
  • Elementary OS;
  • Crunchbang++;
  • Manjaro; and
  • Antergos

Every time I try to boot the system either locks and nothing happens or it returns me the same error:

Kernel panic – not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

I have also tried both booting using an USB flash drive and using CD/DVD. And I have tried booting using Legacy and UEFI.

In the last days I have been to a variety of websites and articles, mainly:

I have also searched the StackExchange network but with no success.

The problem with the purposed solutions is:

a) They are for people who already have Linux in their machines and have corrupted their file-systems;

b) For one to execute the presented solutions a Live CD is needed and I can't even boot Linux so this becomes impossible for me.

My motherboard is Gigabyte B85M-D3PH and my processor is an i5-4460, in case this information helps in any way.

Posting here is my last resort.

  • Does the problem occur when trying to boot from install media, or after install when you try to get into a new system? – Tom Hunt May 27 '15 at 1:02
  • It happens when I try to boot. Sorry for the delay. – Mosaic May 29 '15 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.