-1

I am attempting to complete this GitHub tutorial on creating a custom GRUB loader for a stubborn Asus Win8.1 laptop on which I am hoping to install Ubuntu:

https://github.com/lopaka/instructions/blob/master/ubuntu-14.10-install-asus-x205ta.md

(see screenshot image, blue highlighted text)

../grub-mkimage -d

Assuming I've followed all of the steps in the tutorial,

Does this set of commands instruct the machine to create a ../grub-mkimage directory, or is it telling the machine to go to the ../grub directory and create/refer to a -mkimage file therein?

(The full line of bash commands pulled directly from the tutorial I am referring to, just for reference):

../grub-mkimage -d . -o bootia32.efi -O i386-efi -p /boot/grub ntfs hfs appleldr boot cat efi_gop efi_uga elf fat hfsplus iso9660 linux keylayouts memdisk minicmd part_apple ext2 extcmd xfs xnu part_bsd part_gpt search search_fs_file chain btrfs loadbios loadenv lvm minix minix2 reiserfs memrw mmap msdospart scsi loopback normal configfile gzio all_video efi_gop efi_uga gfxterm gettext echo boot chain eval

Anyway, this is where I've been getting stuck.

Once I get to this point, the machine takes no further action but to acknowledge that the directory is there:

../grub/grub-mkimage: Is a directory

When I attempt to move forward and enter the next command on the tut:

cp bootia32.efi /tmp

The machine replies:

cp cannot stat 'bootia32.efi': No such file or directory

It looks like the long command [../grub-mkimage -d...] did not install the items necessary to execute these processes.

so, if nothing else...

  1. WHAT DOES the hyphenated portion of ./user/location/folder-HyphenatedNameExtension actually mean? It just means it's a file within that folder, right?

and

  1. HOW CAN I re-initiate the ../grub-mkimage -d... long command again without breaking something? Would it be wise to restore my system and start over?
  • Could you edit your question to add the exact error message you get when you try to run ../grub-mkimage? Also, I removed some of the chit-chat (see the help tour). – Stephen Kitt May 25 '15 at 22:49
  • There is no "hyphenated portion": hyphens have no special significance within file or directory names (although there are good reasons to avoid them as initial characters). See What character sequence should I not allow in a filename? – steeldriver May 25 '15 at 23:28
  • @EvanExempt: please include the actual text of the console or terminal which you gave as a image. Text can be indexed by search engines, you image not. – 0xC0000022L May 26 '15 at 19:02
1

The sequence of commands you give clones the grub repository, changes the current directory to that newly created by git (cd grub), builds grub, changes the directory to grub-core, and runs the grub-mkimage executable which is in the parent directory.

More explicitly, if you start off in your home directory (I'll imagine it's /home/evan):

  • git clone ... creates a new directory, /home/evan/grub, and clones grub's repository in it;
  • cd grub changes the directory to /home/evan/grub;
  • the next three commands build grub;
  • cd grub-core changes the directory to /home/evan/grub/grub-core;
  • ../grub-mkimage ... attempts to run the grub-mkimage command stored in /home/evan/grub (the current directory remains /home/evan/grub/grub-core).

.. simply means the parent directory, ../grub-mkimage means "run the grub-mkimage which is in the parent directory". At the point where the command is executed, the current directory is /home/evan/grub/grub-core, and the parent directory is /home/evan/grub.

I ran the commands you listed above, and the build worked fine for me: ../grub-mkimage ... created the expected bootia32.efi file.

To "re-initiate" the command, I'd say the simplest way for you is to delete the grub directory and start over, from the git clone onwards.

  • Thank you for explaining all of this. I've copied this answer to my reference notes. Wonderful. – Evan Exempt May 26 '15 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.