2

I have an Asus Zenbook UX32VD. This laptop has a 500GB HDD and a built in 24GB iSSD (not sure what the i is for).

Since I first got it three years ago I have been installing various linux distributions on the iSSD and mounting /home on the HDD. Currently I use Antergos. This worked very well until the iSSD broke (there are many complaints about this). The problem appears to be something with the soldering, in any case, the iSDD cannot be detected (gparted, bios, etc.). When booting this gives me an error:

error: no such device: 00ea25be-ec8a-4b22-87d2-8ee9c797f273
Entering rescue mode...
grub rescue> _

This happens even if I explicitly choose the HDD from the boot menu.

The laptop is quite old and I do not plan to invest much in fixing the iSSD.

On the HDD the first partition was a 8GB swap partition, followed by the 480 GB home partition. I shrank the swap partition at the beginning to make room for a 300 MB efi partition (at the beginning). I also shrank the home partition by 50 GB (at the end) in order to create a root partition. On this I installed a new Antergos installation. The partitions on the HDD are now (in order): EFI, SWAP, home, root.

The installation ran fine and ended successfully, however upon rebooting I get the same error (with the same UUID). I have tried chrooting into the new installation and rebuilding grub but this does not seem to work.

I checked the grub.cfg file on my new EFI partition and the only UUID it contains is this one (i.e. the new and correct one):

if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  e93abfe5-bfab-4f2b-a90f-6bfa11576fa7
else
  search --no-floppy --fs-uuid --set=root e93abfe5-bfab-4f2b-a90f-6bfa11576fa7

I tried, Antergos, Fedora 22 and Ubuntu 15.04. The live USBs have a problem booting, after which they do eventually succeed (this was Ubuntu 15.04).

[    7.760771] ACPI PCC probe failed.
starting version 219
[    9.179958] sd 6:0:0:0:0 [sdb] No Caching mode page found
[    9.179959] sd 6:0:0:0:0 [sdb] Assuming drive cache: write through
[   17.890052] ata2: COMRESET failed (errno=-16)
[   27.910672] ata2: COMRESET failed (errno=-16)
[   62.974831] ata2: COMRESET failed (errno=-16)
[   68.009151] ata2: COMRESET failed (errno=-16)
[   68.009178] reset failed, giving up

After this the live USBs boot (only in UEFI mode though).

How can I get grub to find my new installation and stop looking for the iSDD?

EDIT: a few more things, when I tried to install Ubuntu 15.04 it said something about an existing operating system being detected and that it would be removed, I am not sure if this is my reinstalled Antergos or the original.

Also here is a screenshot of the SATA menu in BIOS, I do not understand why there is a second entry (and I cannot remove it). I've tried switching between AHCI and IDE modes, but it does not seem to make a difference.

enter image description here

Many thanks in advance

1

"iSSD means integrated ssd"

I had a zenbook UX320 which had a hdd with a built in ssd "Combined Hard Drive". Can u give us more info about your harddrive..sda & sdb. If you can boot with a rescue cd and gather all the info. What filesystem is the efi partition. Is your root / on a extended partition or primary ?

To be sure i would advise you to make a backup of all your data from your /home dir. After this wipe all the drive and do a clean install from your prefered linux distro. Or try to manual install grub2 on sdb.

Maybe this manual will help u to recover/restore/fix grub2. https://help.ubuntu.com/community/Grub2/Installing

  • thanks Ray. The SSD is separate. My HDD also stopped working. Not sure if this is a coincidence. I will try and replace it and reinstall. Thanks – Bastiaan Quast May 31 '15 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.