0

I am trying to use minicom for my serial cable communication to the target but I am not able to access the / of my remote device.I tried setting up ttyXX for minicom using sudo minicom -s but still I am not able to access it.

dmesg output:

  [    0.000000] console [tty0] enabled
  [    0.796017] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
  [    0.999377] 00:0a: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
  [    1.019651] 0000:00:16.3: ttyS4 at I/O 0xf0e0 (irq = 19) is a 16550A

and I tried setting up ttyS0 and ttyS4 but it didn't worked in both the cases.

Minicom setup

+-----------------------------------------------------------------------+
| A -    Serial Device      : /dev/ttyS0                                |
| B - Lockfile Location     : /var/lock                                 |
| C -   Callin Program      :                                           |
| D -  Callout Program      :                                           |
| E -    Bps/Par/Bits       : 115200 8N1                                |
| F - Hardware Flow Control : No                                        |
| G - Software Flow Control : No                                        |
|                                                                       |
|    Change which setting?                                              |
+-----------------------------------------------------------------------+

After setting up if I run sudo minicom it hangs by showing below messages.

Welcome to minicom 2.5
OPTIONS:I18n                                                            
Compiled on May  2 2011, 10:05:24.
Port dev/ttyS0
Press CTRL-A Z for help on special keys 

System Info

 Linux XXXXXXX 3.2.0-83-generic #120-Ubuntu x86_64 x86_64 x86_64 GNU/Linux

Remote target Info

Freescale arm board with ubuntu 32 bit running What am I missing?

  • Hi! Can you provide any information about your remote hardware and OS it runs? – happycorsair May 25 '15 at 7:54
  • @happycorsair: Yeah sure. It is a freescale arm board with ubuntu 32 bit running. – Thushi May 25 '15 at 8:31
  • Got it. Which cable do you use to connect your PC and the board? – happycorsair May 25 '15 at 8:48
  • @happycorsair : DB9 female to DB9 female cable – Thushi May 25 '15 at 10:55
  • Are you sure, that it has null modem wiring? – happycorsair May 25 '15 at 11:02
1
+150

If you are sure about the settings (Baud, parity, flow control) you use, I think that minicom does not "hang" but rather just "does not show anything". If it is female-to-female I would suspect the cable just does not "cross" TX and RX, this means that both source computer and target computer "speak" on the same line and "listen" on the same line (like when you hold your cell phone to your head upside down).

Usually these lines are pin 2 and 3 on D-SUB when using RS-232. Usually it does not do any damage if you just give it a try.

It will not bring any insight, but maybe you want to try another terminal program, like:

microcom -s 115200 /dev/ttyS0
  • Ok...I found the problem. It was problem with my target debug cable.Checked with multimeter :( Anyhow thanks for the answer.Enjoy the bounty :) – Thushi Jul 24 '15 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.