I have been trying to set up a DHCP server on CentOS 6 running on an Intel NUC i7. I have installed dhcpd and am using the example dhcpd.conf

subnet netmask {
    option routers;
    option subnet-mask;
    option domain-name    "xtreemfs.org";
    option domain-name-servers;
    option time-offset    -25200; # GMT - 7

What I have tried:
1. Making sure that there is a file in /var/lib/dhcpd/ called dhcpd.leases
2. Making sure that my dhcpd.conf file is not missing any terminators (;)
3. Editing the /etc/sysconfig/dhcpd file to use eth0
4. Rebooting the system

When I try to start the server (sudo service dhcpd restart) it says:

Starting dhcpd:        [FAILED]

Here are my questions:
1. Is there a way to find out what is causing the failure (looking at some log)?
2. What can I do to solve the issue?

(If anyone is wondering my setup consists of 3 Intel NUC i7 computers connected to a 1000/T eth switch and none of the computers are connected to my local network. My goal is to setup one of the computers as a DHCP server for the other two.)

  • 1
    Have you considered reading the logs? You're not really supposed to debug network problems using your ESP abilities, you know.
    – lcd047
    May 25, 2015 at 5:05
  • In my question I inquired as to where the logs would be stored. So, yes I know I need to read the logs, I just have no idea where I would find them. May 27, 2015 at 2:29
  • 1
    According to the manual: Normally, dhcpd will log all output using the syslog(3) function with the log facility set to LOG_DAEMON. But for a quick check you can also run dhcpd with option -d.
    – lcd047
    May 27, 2015 at 4:28

1 Answer 1


I solved the problem after reading the messages file in /var/log:

less /var/log/messages

This showed me that the issue was that there was no configured listen device. To solve this problem I added eth0 to my /etc/sysconfig/dhcp/dhcpd.conf file and everything worked fine.

  • You may mean /etc/sysconfig/dhcpd if you're changing DHCPDARGS= to include eth0. The problem is, you may not need to edit this, typically, as it'll listen on all interfaces if you let it. It's a great way to ensure it ignores other (not mentioned) interfaces, though, even if that's not the problem you may have been reporting. Are you sure this is what solved your problem? Aug 28, 2015 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.