2

I recently installed Bluedevil on my Fedora 21 XFCE notebook to be able to use my AS-600 bluetooth headphones, and they worked pretty well, the problem now is that whenever I mute the audio by running amixer set Master toggle -q I can't un-mute it by running it again, I have to head to the mixer and manually un-mute it by clicking on the small speaker icon under the speaker:

Before "muting":

enter image description here

In "muted" state:

enter image description here

After "un-muting":

enter image description here

As you can see, the amixer set Master toggle -q command mutes both the Master and Speaker channels but it only un-mutes the Master channel when run again, I have to note that this didn't happen before installing bluedevil and pulseaudio-bluetooth, and uninstalling them just didn't do the trick.

0

There seems to be some bug between ALSA and Pulseaudio.

To fix this, set the device flag to pulse:

amixer -D pulse sset Master toggle -q

(source: arch wiki)

  • I started using pulse (pavucontrol) instead of alsamixer to control the volume and many issues have been gone, but I can confirm that by manually specifying the device flag this issue is solved. – arielnmz Nov 7 '16 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.