0

This is my first time experience with any Linux OS. I am trying to dual boot linux Mint to my Toshiba Satellite Win 8.1 laptop(64 bit). I searched google on how to dual boot linux mint and below are the steps I have done so far:

  1. Created a manual partition in my Win 8 laptop.
  2. Downloaded linuxmint-17.1-cinnamon-64bit iso file via torrent. I have burnt the iso file to my USB memory stick using unetbootin tool(unetbootin-windows-608).
  3. As suggested I have disabled secure boot and my Boot mode is set as UEFI by default.

Now when I reboot I do get the below 2 options:

  1. Start Linux Mint
  2. Start Linux Mint with compatibility mode

Either option I choose gives me a blank screen and nothing much. I am not sure what is the issue and how to proceed further.

1
  • My advice (read help→tour) and leave out the chit-chat like "Thanks" and your name (a second time) from posts in the future.
    – Anthon
    Commented May 23, 2015 at 22:09

1 Answer 1

0

It's hard to determine the cause of the problem. It could be that you chose incorrect partition during installation and/or the installer was not downloaded completely or something else.

I suggest you use Windows-recovery-DVD or something like that to recover your Windows as well as recovering the initial partition. As for installation of linux-mint, you better verify installer you downloaded from torrent using md5sum and organize the partition in linux-mint installation directly to avoid confusion.

Alternatively, you can also use gparted which can be installed to flash drive to manage your partition, but please be careful not to delete or modify (shrink or extend) partition that you are not sure about because this program is designed to do that in simple manner using GUI.


What you said is identical to what describes in tutorial for linux mint installation. I have no experience in Win 8, but I surfed a little bit and I found out that this EFI/UEFI is designed mainly for Win and one of the purpose is to avoid booting using other OSes as described here. But it seems there is a way to force EFI (or UEFI) to allow linux to installed there instead of CSM as described here.

4
  • I checked the md5sum and it does matches with the downloaded file. I reformatted my USB stick and installed the boot files again. On reboot i get the grub menu with 2 options: 1. Start Linux Mint 2. Start Linux Mint with Compatibility mode Either option I select gives me a blank screen.When I change the Boot Mode from UEFI mode to CSM Mode and selecting any of the options from grub menu gives me Linux Mint home screen
    – Sachin
    Commented May 24, 2015 at 15:39
  • Ah, I had no idea it was the boot mode. You better put it as an answer in case anyone else get the same problem.
    – Franky
    Commented May 24, 2015 at 15:49
  • But the problem is every other time i need to log into Windows i get an error and i need to change the Boot Mode to UEFI. Does that means Linux Mint is not supported my my Laptop in UEFI mode ?
    – Sachin
    Commented May 24, 2015 at 17:11
  • What you said is identical to what describe in this [tutorial] (community.linuxmint.com/tutorial/view/1556) for linux mint installation. I have no experience in Win 8, but I browse a little bit and I found out that this EFI/UEFI is designed mainly for Win and one of the purpose is to avoid booting using other OSes as described here. But it seems there is a way to force EFI (or UEFI) to allow linux installed there instead of CSM as described here.
    – Franky
    Commented May 25, 2015 at 3:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .