3

Last night I attempted to update my PC from Debian 7, Wheezy (now old stable), to Debian 8, Jessie (now stable). On rebooting, the system broke at 0.267166 minutes into the launch telling me it can't find the hard disk. The entire operating system is on a single software RAID disk, which wasn't my first choice, spaning two 250GB hard disks in a Raid 0 system. This worked in Wheezy but is not working since I tried to update to Jessie.

The GRUB configuration is:

setparams 'Debian GNU/Linux'

    load_video
    insmod gzio
    if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
    insmod part_msdos
    insmod part_msdos
    insmod diskfilter
    insmod mbraid1x
    insmod ext2
    set root='mduuid/d9fbcc87d121184a2fb58c97c2be2174'
    if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid --set=root --hint='mduuid/d9fbcc87d121184a2fb58c97c2174' 0369663c-69ae-4f58-9496-30525afc47d2
    else
        search --no-floppy --fs-uuid --set=root 0369663c-69ae-4f58-9496-30525afc47d2
    fi
    echo        'Loading Linux 3.16.0-4amd64 ...'
    linux       /boot/vmlinz-3.16.0-4-amd64 root=UUID=0369663c-69ae-4f58-9496-30525afc47d2 ro quiet
    echo        'Loading initial ramdisk ...'
    intrd        /boot/intrd.img-3.16.0-4-amd64

To which it responds that it can't read from hd0. It then goes to the standard output (a black and white terminal) with numerous errors and debugging information including a call stack trace and the kernel panic error stating that it cannot mount the file system located at block(0,0).

What I want to know is how do I fix this issue? It would seem that the raid array is not innitialzing. And in the event that this cannot be fixed would it be better to do a fresh install for Jessie or is it not as stable as they say making it better to do a fresh install of Wheezy? If I have to do a fresh install, I won't be messing around with software RAID again.

  • @MaurolepisDreki OK, I'll convert my comments to an answer. Please report the image upload error as a bug (along with browser/OS/etc. details, steps to reproduce, etc.) on Unix & Linux Meta. – derobert May 22 '15 at 21:24
  • 1
    It seems that your problem is the same as the one I ran into. I reported a bug which contains suggestions for the solution: bugs.debian.org/cgi-bin/bugreport.cgi?bug=789150 – user119949 Jun 18 '15 at 10:35
2

For some reason, your initramfs is failing to start your RAID array. That could mean it just wasn't configured to, or that it was somehow generated wrong. Since you're able to boot from a recovery disk, you can easily change the setting and regenerate it using the following commands:

  1. dpkg-reconfigure mdadm. You should be asked which arrays to start in the initramfs, you need to have at least your array here, or just all.
  2. update-initramfs -u -a. This updates all of your initramfses. It may take a minute.

Finally, if grub is additionally giving warnings, dpkg-reconfigure grub-pc will probably fix it. When prompted about where to install grub, you most likely want to pick both of your disks (e.g., /dev/sda and /dev/sdb). This will also take a few seconds.

|improve this answer|||||
  • This solution works, but to make it work I had to use Finnix Live CD, mount the RAID disk, and use chroot before reconfiguring mdadm. It seems that Debian 8's native mdadm configure script may be what was causing the problem. – user116452 May 22 '15 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy