1

I am running Linux Mint 17, Cinnamon 2.4.8

Hello, I am using ImageMagick to create large 500+ png images.

This causes Cinnamon to go very slow.

I would understand if Cinnamon is slow WHILE I am rendering many images, however, Cinnamon is really slow even AFTER the renders are complete.

The only way to remedy this is to do a reboot, but I would really like another solution if possible.

Command free BEFORE render

             total       used       free     shared    buffers     cached
Mem:      16384584    1066072   15318512      20212      61948     407592
-/+ buffers/cache:     596532   15788052
Swap:     16727036          0   16727036

Command free DURING render

             total       used       free     shared    buffers     cached
Mem:      16384584    1230524   15154060      21148      69540     457700
-/+ buffers/cache:     703284   15681300
Swap:     16727036          0   16727036

Command free AFTER render

             total       used       free     shared    buffers     cached
Mem:      16384584    1263932   15120652      20760      70416     460352
-/+ buffers/cache:     733164   15651420
Swap:     16727036          0   16727036
  • Check the output of free before and after running the image processing job. Also check top when your system is slow: is the CPU busy, and if so, what processes are keeping it (press P to sort processes by CPU usage time)? – Gilles 'SO- stop being evil' May 22 '15 at 21:06
  • Hello, I updated my question with the output of free. There is nothing that seems to be related to imagemagick from my top output – TuxForLife May 23 '15 at 16:57
  • Before and after. What's interesting is the difference. And the top output is relevant whether there's anything IM-related — how much CPU is used, and by what process if not IM? – Gilles 'SO- stop being evil' May 23 '15 at 18:45
  • @Gilles there updated sorry about that. It's weird, the used is even higher even after the render. It's pretty weird that it increases after the process is completed – TuxForLife May 23 '15 at 20:09
  • By the way, did you check for temporary files left over in a tmpfs filesystem, which shivams already suggested? – Gilles 'SO- stop being evil' May 23 '15 at 21:44
1

Memory Issue

This is most probably a memory issue.

One thing to do is to limit the memory usage of imagemagick. As mentioned here: -limit type value, you can limit your usage using these options:

-limit memory 512MiB -limit map 512MiB

Further, as you're saying that it is slow even AFTER imagemagick is run, in that case look for some ghost processes left over by imagemagick which are making it not release the RAM. And kill those processes.

ps aux | grep convert    #assuming you used convert

Another Possibility : Disk full due to temporary files

Check your /tmp directory or some other directory it might be storing its temporary files and see if that corresponding to it has space or not. That might be a probably reason. Reboot usually deletes temp files and relieves space.

| improve this answer | |
  • Do you think lowering the memory will make my renders slower? The render speed is a bit important to me. I did get the following from ps aux | grep convert eric 21358 0.0 0.0 11748 2156 pts/2 S+ 20:38 0:00 grep --colour=auto convert but I think it's from the grep command itself. I found nothing in /tmp that seemed to correlate with ImageMagick. – TuxForLife May 22 '15 at 3:40
  • which tool from imagemagick are you using? – shivams May 22 '15 at 8:01
  • convert and identify – TuxForLife May 22 '15 at 13:52
  • 1
    I updated to the NVIDIA 352.09 driver today, and I believe it has been the ultimate remedy! – TuxForLife May 31 '15 at 3:28
  • 1
    Okay. So, did updating NVIDIA driver fix your problem finally? If yes, then good to hear :) – shivams May 31 '15 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.