5

When I press m to send a new email in Mutt, it first asks for the recipient ("To" header), and then for the Subject. After that, it opens the email in Vim so I can actually write my email.
I've set edit_headers in my muttrc file so that I can just add recipients and such from Vim, so the contents of the new file is:

From: Martin Tournoij <martin@arp242.net>
To: example@example.com
Cc:
Bcc:
Subject: Hey there
Reply-To:

The issue is, I use a Vim function to complete email addresses, so I don't know the correct email address before I've started Vim. I work around this by filling in "asdf" or some such when mutt asks for the recipient.

Is there any way I can tell mutt to skip asking for the recipient? I would prefer if it would only skip the recipient, and that it continues to ask for the Subject, but skipping both (and going straight to Vim) would also be okay.

6

Setting autoedit=yes, composing will go directly to the message editor without prompting for recipient or subject.

Note that you must also have edit_headers set.

As @lcd047 mentions, this feature inhibits all the send hooks before calling the editor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.